Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Página 1 de 5. 1, 2, 3, 4, 5  Siguiente

Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Gracias

Mensaje  Frankie el Lun Ene 23, 2012 11:28 pm

Pues lo dicho.... Una vez más , muchísimas gracias por vuestro esfuerzo !!!

Frankie

Mensajes : 3
Fecha de inscripción : 02/07/2010
Edad : 52
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty No se instala LGMENU

Mensaje  ruanorecords el Mar Ene 24, 2012 12:57 pm

Hola! Lo primero quiero agradecer este tipo de actualización. Quería comentar, que no se si le habrá pasado a alguien, pero consigo instalar la primera parte, con el Update, pero el LG Menu no consigo instalarlo. Cuando debo hacer el Reinicio (Paso 10 del PDF de la versión 1.3), Debo hacerlo pulsando el boton Reset cuando está en la pantalla INIT de Configuraciones Básicas o debo apagarlo y encenderlo de nuevo? Si lo hago en el INIT vuelve de nuevo al INIT indicandome que haga las configuraciones básicas...

De todas formas, he probado de todas las maneras, y no hay forma!!.

Gracias de antemano!

Un saludo

Diego

ruanorecords

Mensajes : 3
Fecha de inscripción : 13/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  vic1972 el Mar Ene 24, 2012 1:53 pm

ruanorecords escribió:Hola! Lo primero quiero agradecer este tipo de actualización. Quería comentar, que no se si le habrá pasado a alguien, pero consigo instalar la primera parte, con el Update, pero el LG Menu no consigo instalarlo. Cuando debo hacer el Reinicio (Paso 10 del PDF de la versión 1.3), Debo hacerlo pulsando el boton Reset cuando está en la pantalla INIT de Configuraciones Básicas o debo apagarlo y encenderlo de nuevo? Si lo hago en el INIT vuelve de nuevo al INIT indicandome que haga las configuraciones básicas...
De todas formas, he probado de todas las maneras, y no hay forma!!.
Gracias de antemano!
Un saludo
Diego

Hola Diego, bienvenido al foro.
Entiendo que partes de un firmware oficial verdad? Sin tener previamente instalado el lg menu, cierto?

Vale, la primera parte del firmware ya lo tienes, es el fichero .img de la llave usb.

Ahora, te queda la segunda lgmenu.
Asegurate que en el raiz de la llave usb tienes exactamente el archivo: Custom-KV-v108-IV.tar.gz

Apaga y enciendo con la llave usb dentro, y nada mas, fijate como el led de la usb empieza a trabajar,
y en approx. un minuto cuando acaba la instalacion de lgmenu el solo hace un reboot.
suerte






vic1972
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 47
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  ruanorecords el Mar Ene 24, 2012 3:15 pm

vic1972 escribió:
ruanorecords escribió:Hola! Lo primero quiero agradecer este tipo de actualización. Quería comentar, que no se si le habrá pasado a alguien, pero consigo instalar la primera parte, con el Update, pero el LG Menu no consigo instalarlo. Cuando debo hacer el Reinicio (Paso 10 del PDF de la versión 1.3), Debo hacerlo pulsando el boton Reset cuando está en la pantalla INIT de Configuraciones Básicas o debo apagarlo y encenderlo de nuevo? Si lo hago en el INIT vuelve de nuevo al INIT indicandome que haga las configuraciones básicas...
De todas formas, he probado de todas las maneras, y no hay forma!!.
Gracias de antemano!
Un saludo
Diego

Hola Diego, bienvenido al foro.
Entiendo que partes de un firmware oficial verdad? Sin tener previamente instalado el lg menu, cierto?

Vale, la primera parte del firmware ya lo tienes, es el fichero .img de la llave usb.

Ahora, te queda la segunda lgmenu.
Asegurate que en el raiz de la llave usb tienes exactamente el archivo: Custom-KV-v108-IV.tar.gz

Apaga y enciendo con la llave usb dentro, y nada mas, fijate como el led de la usb empieza a trabajar,
y en approx. un minuto cuando acaba la instalacion de lgmenu el solo hace un reboot.
suerte

Hola Vic!

Lo Primero, gracias por contestar tan rápido! Nada, no lo consigo. Te cuento lo que hago paso a paso... Y así saber donde puedo estar cometiendo el error. Lo priemro de todo, tengo el MS450. Paso a un Pen Drive los 2 Archivos, el "MS400_101119_0128" y el "Custom-KV-v108-IV.tar". Depués apago el LG y meto el PenDrive en el USB Delantero. Presiono el botón círculo y le doy al power, y mantengo presionado unos 10 segundos. Me aparece el UPDATE y lo hace OK. Se reinicia solo, y ya me aparece el INIT, Saltándose la Opción "Display Menu" y llevándome directamente a "Region". Realizo la Configuración Básica... Auto Programing (dejo que busque todos los canales), en Time selecciono Auto y Auto tambien en Time Zone. En Wired LAN Setup lo dejo en Auto y Wireless Setup le doy a cancel (Ya que no tengo conectado el Adaptador WIFI y si tenerlo conectado por Red "RJ45". Una vez finalizada la conf básica me sale el Menú de HOME del LG. donde procedo a apagarlo y a volverlo a encender (Ya tenía caragdo el Custom-KV-v108-IV.tar anteriormente por lo que no lo saco en ningún momento". Al enceder de nuevo el LG, el USB se enciende, parapdea un poco como que lo ha reonocido, y ahí se queda. Espero 10 Minutos, y vuelvo a apagar y enceder de nuevo el LG, y hace lo mismo, sin reiniciarse ni nada... Comentar, que nada más encender el LG no se quda en el HOME sino que se va a la TDT Directamente. Espero poderlo solucionar!

Un saludo y muchas Gracias!

Diego

ruanorecords

Mensajes : 3
Fecha de inscripción : 13/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  vic1972 el Mar Ene 24, 2012 6:14 pm

Hola,
como se te dan los comandos por telnet en linux ?

yo lo que haria es borrar /tmp/hdd/root/custom
y lanzar de nuevo la instalacion ejecutando
/usr/local/etc/starthdservices.sh

y ver el log /tmp/hddservice.log
suerte
vic1972
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 47
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  ruanorecords el Mar Ene 24, 2012 6:17 pm

vic1972 escribió:Hola,
como se te dan los comandos por telnet en linux ?

yo lo que haria es borrar /tmp/hdd/root/custom
y lanzar de nuevo la instalacion ejecutando
/usr/local/etc/starthdservices.sh

y ver el log /tmp/hddservice.log
suerte

Bufff... La verdad que Linux un poco mal... Tengo Windows y Mac instalados... Y en un portatil "Netbook" tengo instalado Ubuntu... Si me comentas mas o menos paso a paso como hacerlo o si está escrito ya en el foro, ya que en eso soy totalmente principiante. Te lo agaradezco de verdad!

Saludos y Muchas Gracias!

ruanorecords

Mensajes : 3
Fecha de inscripción : 13/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Exactamente el mismo problema

Mensaje  berdini el Mar Ene 24, 2012 10:03 pm

Lo dicho en el titulo tengo EXACTAMENTE el mismo problema que ruanorecords (y ya lo he tenido con la version anterior del firmware). He probado con distintos pen y nada. No he realizado el Telnet pero sí he formateado el disco duro para eliminar cualquier carpeta y comenzar de cero pero tampoco he podido. Yo tengo el 400.

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty No puedo acceder desde LG menu

Mensaje  amperio el Miér Ene 25, 2012 1:08 am

Gracias por el aporte de Harmony. Se me ha instalado bien la primera parte, pero cuando intento acceder al LG (en mi caso http://192.168.0.102/) desde el navegador (Google Chrome), éste no la localiza y dice "esta web no está disponible". El caso es que el LG me reconoce la red, puedo acceder al You Tube, y puedo ver las películas que tengo almacenadas en un disco de red. No sé si es que no se me habrá instalado el LG menú. NOTA: Sí puedo acceder a él con el Administrador web que tenía previamente instalado. ¿Qué pasará?

amperio

Mensajes : 13
Fecha de inscripción : 30/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Seinto decir que yo tambien tengo problemas con la ultima parte de la instalación.

Mensaje  rtc el Miér Ene 25, 2012 7:21 am

El último reinicio no lo hace y no aparece el servidor web. En cambio, el servidor de telnet sí está operativo. Contenta al ping t permite entrar por telner.
Ahora probaré las secuencias qe habeis comentado anteriomente.

En cuanto a Linux o windows... me gusta más el telnet de linux, pero desde windows también se puede hacer.

desde \windows\system32 podeis ejecuar el telnet igual que si estuvieseis en linux.

Ya os comentaré como van los avances!
Saludos y gracias por el curro que os habeis pegado y la información que nos dais...


rtc

Mensajes : 2
Fecha de inscripción : 02/01/2011

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  amperio el Miér Ene 25, 2012 10:26 am

Sin embargol el ping desde un ordenador de la red es correcto:
Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Pingku

amperio

Mensajes : 13
Fecha de inscripción : 30/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty buscando el error...

Mensaje  rtc el Miér Ene 25, 2012 1:35 pm

Siguiendo las instrucciones me da los siguientes mensajes...

root@Venus:~# cd /tmp/hdd
root@Venus:/tmp/hdd# cd root
root@Venus:~# ls
backup lost+found


root@Venus:~# l
total 15
drwxrwxrwx 4 root root 1024 Jan 25 11:20 .
drwxr-xr-x 7 500 500 0 Dec 18 16:35 ..
-rw------- 1 root root 50 Jan 25 11:21 .ash_history
drwxr-xr-x 2 root root 1024 Jan 25 01:49 backup
y el fichero lost+found que no me ha salido en el volccado, pero no hay ni fichero ni directorio custom

root@Venus:~# /usr/local/etc/starthddservices.sh
swapon: /dev/scsi/host0/bus0/target0/lun0/part2: Device or resource busy
/usr/local/etc/starthddservice.sh: line 107: ./performUpdate.sh not found

el contenido de /tmp/hddservice.log:
2012-01-25 11:17:17 : Checking HDD presence...
2012-01-25 11:17:36 : HDD is ready after 18 seconds.
2012-01-25 11:17:38 : waiting for USB: 27s
2012-01-25 11:18:05 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:18:10 : Unpacking installation package...
2012-01-25 11:21:51 : Checking HDD presence...
2012-01-25 11:21:51 : HDD is ready after 0 seconds.
2012-01-25 11:21:53 : waiting for USB: 45s
2012-01-25 11:22:38 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:22:41 : Unpacking installation package...

Parece que no encuentra el fichero performUpdate.sh

Quizás lo he ejecutado desde un directorio incorrecto y por eso no lo encuentra....

Espero que alguien tenga alguna idea... thnx!

rtc

Mensajes : 2
Fecha de inscripción : 02/01/2011

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  JBL el Sáb Ene 28, 2012 9:07 pm

Hola foreros, uno que ha dado marcha atras, el wifi lo pierde al poco de iniciar el cacharrin y esto no me pasa con el anterior, graro, graro...

Un Saludote.

JBL

Mensajes : 130
Fecha de inscripción : 06/09/2010
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Instalación del Custom

Mensaje  Fuser el Dom Ene 29, 2012 3:14 pm

Hola,

quisiera aportar mi granito de arena.

Al igual que a algunos compañeros a mí tampoco se me instalaba el custom. Yo tenía el anterior firmware y custom, después realicé una instalación del firmware oficial y ahora había vuelto a poner el firmware 1.4 pero no me reiniciaba el aparato tras el primer INIT.

Bueno, mirando, mirando, he visto que el starthddservice.sh descomprimía el fichero custom en un directorio temporal, pero creando un nuevo directorio al cual al final no accedía, intentaba ejecutar performUpdate.sh desde el directorio padre.

NOTA > No os olvidéis de hacer copia de seguridad del starthddservice original:
cp /usr/local/etc/starthddservices.sh /usr/local/etc/starthddservices.sh.ORIG

Así pues he modificado el instalador starthddservice.sh de la siguiente forma (en negrita los cambios):
--------
Fichero /usr/local/etc/starthddservices.sh
Editar/cambiar/copiar y pegar desde la siguiente línea de guiones
---------------------------
#!/bin/sh

count=0
hddready=0
checkusb=1
maxusbwait=45

MAX_COUNT=240
HDDSERVICELOG=/tmp/hddservice.log
CHECKDIR=/tmp/IMSMETA
INSTPACKAGE="Custom-KV-v*.tar.gz"
INSTDIRECTORY="Custom-KV-v*"
TGTEMP=/tmp/hddmedia/lg/installation
CUSTOMHOME=/tmp/hdd/root/custom

SWAP1=/dev/scsi/host0/bus0/target0/lun0/part2
SWAP2=/dev/scsi/host1/bus0/target0/lun0/part2

timestamp() {
date "+%Y-%m-%d %H:%M:%S"
}

# Check HDD presence
echo `timestamp`" : Checking HDD presence..." >> $HDDSERVICELOG
while true; do
if [ -d $CHECKDIR ]; then
hddready=1
break
fi
count=$((count + 1))
if [ $count -eq $MAX_COUNT ]; then
hddready=0
break
fi
sleep 1
done

if [ $hddready -eq 0 ]; then
# The disk is not detected
echo `timestamp`" : HDD not ready after $count seconds!" >> $HDDSERVICELOG
else
# HDD is ready, so start all services
echo `timestamp`" : HDD is ready after $count seconds." >> $HDDSERVICELOG
sleep 2
/bin/mkdir -p /tmp/empty
/bin/mkdir -p /tmp/run

# Join swap
if [ -b $SWAP1 ]; then
/sbin/swapon -p 1 $SWAP1
fi
if [ -b $SWAP2 ]; then
/sbin/swapon -p 1 $SWAP2
fi

# Make a backup directory
mkdir -p /tmp/hdd/root/backup

if [ $count -lt $maxusbwait ]; then
sleeptime=$((maxusbwait - count));
echo `timestamp`" : waiting for USB: "$sleeptime"s" >> $HDDSERVICELOG
sleep $sleeptime
fi

# Check the USB presence
if [ ${checkusb} -eq 1 ]; then
for usbmount in `ls /tmp/usbmounts/`; do
packages=`ls /tmp/usbmounts/${usbmount}/${INSTPACKAGE}`
for p in ${packages}; do
echo `timestamp`" : Accessing installation package $p" >> $HDDSERVICELOG
# Create and clean temporary place
rm -fr $TGTEMP >/dev/null 2>/dev/null
mkdir -p $TGTEMP
cp ${p} $TGTEMP
cd $TGTEMP
echo `timestamp`" : Unpacking installation package..." >> $HDDSERVICELOG
gunzip -c `basename ${p}` | tar xf -
# Borramos fichero comprimido
rm -rf ${INSTPACKAGE}
# Accedemos al directorio donde estan los archivos
cd ${INSTDIRECTORY}
# Run update script from package
echo `timestamp`" : Directorio activo: "`pwd` >> $HDDSERVICELOG

./performUpdate.sh >> $HDDSERVICELOG
done
done
fi

# Start all init scripts in /etc/init.d
# executing them in numerical order.
if [ -d "$CUSTOMHOME" ]; then
for i in $CUSTOMHOME/etc/init.d/S??* ;do
# Ignore dangling symlinks (if any).
[ ! -f "$i" ] && continue

case "$i" in
*.sh)
# Source shell script for speed.
(
trap - INT QUIT TSTP
set start
. $i
)
;;
*)
# No sh extension, make sequential starting
$i start
;;
esac
done
fi
fi
#Copiar hasta aquí
# Fin del archivo
------------------------------------------------

Espero haberos sido de ayuda, si alguien no sabe cómo editar el fichero desde terminal, ya le daré un par de claves para usar vi, Smile

Salu2

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Fallo en Torrent

Mensaje  telepac el Dom Ene 29, 2012 11:58 pm

Hola,

Ante todo felicidades por el gran trabajo realizado. La verdad es que he tenido la versión anterior y me iba genial sobre todo en mi caso para el FTP y el Torrent. Decidí cambiar a esta versión pero me falla el torrent, no se si le pasará a alguien más. En una de las versiones anteriores leí que a alguien le fallaba también y que se solucionaba poniendo el DNS correcto y/o actualizando el PM pero en mi caso eso es correcto. El primer sintoma era que no conseguia añadir ningún torrent, al final accediendo directamente al transmission usando el puerto 9091 conseguí que funcionara pero al añadir el torrent me aparece un error "Error: Unable to save resume file: No such file or directory". He leido en algún foro que puede ser un tema de permisos y que se soluciona pasandole en el arranque del demonio los directorios de configuracion y de descargas. ¿Hay alguien más con este problema?.



Un saludo.


Última edición por telepac el Miér Feb 01, 2012 7:58 pm, editado 1 vez

telepac

Mensajes : 5
Fecha de inscripción : 20/07/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty RE: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  gizbo84 el Lun Ene 30, 2012 1:22 pm

Antes de todo muchas gracias por este gran aporte!!!!!

He actualizado con el método 1 y no he tenido ningún problema durante la instalación pero no me puedo conectar mediante el menú web. No tengo problemas de conectividad, llego por ping y Telnet. ¿hay que configurar o activar algo más? ¿Cómo puedo comprovar si se ha instalado correctamente?

gizbo84

Mensajes : 11
Fecha de inscripción : 27/06/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Fuser el Lun Ene 30, 2012 1:52 pm

gizbo84 escribió:Antes de todo muchas gracias por este gran aporte!!!!!

He actualizado con el método 1 y no he tenido ningún problema durante la instalación pero no me puedo conectar mediante el menú web. No tengo problemas de conectividad, llego por ping y Telnet. ¿hay que configurar o activar algo más? ¿Cómo puedo comprovar si se ha instalado correctamente?

Hola,

¿te ha hecho un segundo reinicio después de entrar por primera vez en el INIT?

Tal vez te pase lo que al forero rtc y a mí... ¿Has visto mi respuesta un par de posts más arriba?

Tienes que entrar por telnet y luego teclear la siguiente línea, tal cual, para que ejecute la instalación de custom, creo que ahí es donde se coloca la web:
/usr/local/etc/starthddservices.sh

Si te va bien, el LG se te reiniciará cuando acabe el proceso. Si no, una vez lo tengas hecho, mira a ver si te sale algo similar a lo que decía rtc con el comando:
cat /tmp/hddservice.log


el contenido de /tmp/hddservice.log:
2012-01-25 11:17:17 : Checking HDD presence...
2012-01-25 11:17:36 : HDD is ready after 18 seconds.
2012-01-25 11:17:38 : waiting for USB: 27s
2012-01-25 11:18:05 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:18:10 : Unpacking installation package...
2012-01-25 11:21:51 : Checking HDD presence...
2012-01-25 11:21:51 : HDD is ready after 0 seconds.
2012-01-25 11:21:53 : waiting for USB: 45s
2012-01-25 11:22:38 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:22:41 : Unpacking installation package...

Parece que no encuentra el fichero performUpdate.sh

Sigue entonces la modificación del fichero que posteé ayer.

Ah y no te olvides de volver a ejectuar starthddservices.sh otra vez!! Smile

Un saludo,

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  berdini el Mar Ene 31, 2012 12:00 am

ruanorecords escribió:
vic1972 escribió:Hola,
como se te dan los comandos por telnet en linux ?

yo lo que haria es borrar /tmp/hdd/root/custom
y lanzar de nuevo la instalacion ejecutando
/usr/local/etc/starthdservices.sh

y ver el log /tmp/hddservice.log
suerte

Bufff... La verdad que Linux un poco mal... Tengo Windows y Mac instalados... Y en un portatil "Netbook" tengo instalado Ubuntu... Si me comentas mas o menos paso a paso como hacerlo o si está escrito ya en el foro, ya que en eso soy totalmente principiante. Te lo agaradezco de verdad!

Saludos y Muchas Gracias!

despues del Telnet...

el contenido de /tmp/hddservice.log:
2012-01-30 21:50:13 : Checking HDD presence...
2012-01-30 21:54:16 : HDD not ready after 240 seconds!


No lo entiendo pq el HDD nunque me ha dado ningún problema. (Tengo el LG 400)

Además no existe la carpeta custom en /tmp/hdd/root/ sólo aparecen lock y recovery

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  gizbo84 el Mar Ene 31, 2012 12:44 am

Fuser escribió:
gizbo84 escribió:Antes de todo muchas gracias por este gran aporte!!!!!

He actualizado con el método 1 y no he tenido ningún problema durante la instalación pero no me puedo conectar mediante el menú web. No tengo problemas de conectividad, llego por ping y Telnet. ¿hay que configurar o activar algo más? ¿Cómo puedo comprovar si se ha instalado correctamente?

Hola,

¿te ha hecho un segundo reinicio después de entrar por primera vez en el INIT?

Tal vez te pase lo que al forero rtc y a mí... ¿Has visto mi respuesta un par de posts más arriba?

Tienes que entrar por telnet y luego teclear la siguiente línea, tal cual, para que ejecute la instalación de custom, creo que ahí es donde se coloca la web:
/usr/local/etc/starthddservices.sh

Si te va bien, el LG se te reiniciará cuando acabe el proceso. Si no, una vez lo tengas hecho, mira a ver si te sale algo similar a lo que decía rtc con el comando:
cat /tmp/hddservice.log


el contenido de /tmp/hddservice.log:
2012-01-25 11:17:17 : Checking HDD presence...
2012-01-25 11:17:36 : HDD is ready after 18 seconds.
2012-01-25 11:17:38 : waiting for USB: 27s
2012-01-25 11:18:05 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:18:10 : Unpacking installation package...
2012-01-25 11:21:51 : Checking HDD presence...
2012-01-25 11:21:51 : HDD is ready after 0 seconds.
2012-01-25 11:21:53 : waiting for USB: 45s
2012-01-25 11:22:38 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:22:41 : Unpacking installation package...

Parece que no encuentra el fichero performUpdate.sh

Sigue entonces la modificación del fichero que posteé ayer.

Ah y no te olvides de volver a ejectuar starthddservices.sh otra vez!! Smile

Un saludo,


Muchas Gracias Fuser!!! Lo he solucionado con tu post anterior.

gizbo84

Mensajes : 11
Fecha de inscripción : 27/06/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Fuser el Mar Ene 31, 2012 10:15 am

berdini escribió:
ruanorecords escribió:
vic1972 escribió:Hola,
como se te dan los comandos por telnet en linux ?

yo lo que haria es borrar /tmp/hdd/root/custom
y lanzar de nuevo la instalacion ejecutando
/usr/local/etc/starthdservices.sh

y ver el log /tmp/hddservice.log
suerte

Bufff... La verdad que Linux un poco mal... Tengo Windows y Mac instalados... Y en un portatil "Netbook" tengo instalado Ubuntu... Si me comentas mas o menos paso a paso como hacerlo o si está escrito ya en el foro, ya que en eso soy totalmente principiante. Te lo agaradezco de verdad!

Saludos y Muchas Gracias!

despues del Telnet...

el contenido de /tmp/hddservice.log:
2012-01-30 21:50:13 : Checking HDD presence...
2012-01-30 21:54:16 : HDD not ready after 240 seconds!


No lo entiendo pq el HDD nunque me ha dado ningún problema. (Tengo el LG 400)

Además no existe la carpeta custom en /tmp/hdd/root/ sólo aparecen lock y recovery

Hola Berdini,

igual es que no tienes el directorio /tmp/IMSMETA creado...

Compruébalo siguiendo éstos pasos:
1. Entra por telnet o ssh.

2. escribe:
ls /tmp/IMS*

si te sale IMSMETA, habrá que ver si es un directorio. Si no te sale, créalo con:

mkdir /tmp/IMSMETA

3. ejecuta:
/usr/local/etc/starthdservices.sh

4. Si se te reinicia el LG cuando acabe, perfecto. Si no, envíanos el log.

Un saludo,

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  berdini el Mar Ene 31, 2012 12:52 pm

Fuser escribió:

Hola Berdini,

igual es que no tienes el directorio /tmp/IMSMETA creado...

Compruébalo siguiendo éstos pasos:
1. Entra por telnet o ssh.

2. escribe:
ls /tmp/IMS*

si te sale IMSMETA, habrá que ver si es un directorio. Si no te sale, créalo con:

mkdir /tmp/IMSMETA

3. ejecuta:
/usr/local/etc/starthdservices.sh

4. Si se te reinicia el LG cuando acabe, perfecto. Si no, envíanos el log.

Un saludo,

GRacias Fuser, ya estoy más cerca, no existía el directorio y lo he creado, ahora en el log aparece el problema que habías comentado. He de editar el starthddservices.sh para añadir las líneas de comandos que comentas pero no sé cómo hacerlo. He probado con el editor vi pero no me aparece todos los comandos que posteas más arriba, sólo las primeras líneas.

Muchas gracias!

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Cursillo de vi

Mensaje  Fuser el Mar Ene 31, 2012 3:00 pm

GRacias Fuser, ya estoy más cerca, no existía el directorio y lo he creado, ahora en el log aparece el problema que habías comentado. He de editar el starthddservices.sh para añadir las líneas de comandos que comentas pero no sé cómo hacerlo. He probado con el editor vi pero no me aparece todos los comandos que posteas más arriba, sólo las primeras líneas.

Venga, vamos con el cursillo de vi. Luego, si eso, ya postearé en un tema más general, o que nos lo muevan los moderadores... Smile

Como medida de precaución, haremos copia de seguridad del fichero en cuestión:
cp /usr/local/etc/starthddservices.sh /usr/local/etc/starthddservices.sh.ORIG

Entramos en el editor vi:
vi /usr/local/etc/starthddservices.sh

Vi tiene dos modos: Edición y movimiento del cursor e introducción de otros comandos. Nada más entrar y ver el contenido del fichero, estamos en modo "Movimiento".

Para mover el cursor, se utilizan las flechas arriba, abajo izquierda y derecha, pero si éstas no van las teclas que funcionan son:
h Izquierda
j Abajo
k Arriba
l Derecha

Si queremos editar un texto pulsamos:
i - Para insertar nuevos caracteres a partir de la posición actual.
a - Para añadir nuevos caracteres a partir de la posición actual.
A - (en mayúscula) para añadir nuevos caracteres a final de línea.

Por ejemplo, si queremos añadir una nueva línea, estando en modo "Movimiento" hacemos lo siguiente:
- ir al comienzo de una línea, a partir de la cual añadiremos las nuevas.
- Pulsar A (abajo aparecerá INSERT para indicar que estamos en modo edición)
- Intro, para crear y pasar a una nueva línea.
- Escribiremos lo que queramos.
- ESC para salir del modo edición.

Para guardar los cambios, cuando estemos en modo "Movimiento", (Muy importante):
: (irá a la parte inferior del fichero)
w (para guardar)
Intro para hacer efectivo el comando.

Si no queremos guardar:
:
q (indica que queremos salir)
! (Indica que no queremos guardar)
Intro

Si queremos guardar y salir, todo a la vez:
:
w
q
Intro

Info ampliada:
http://www.washington.edu/computing/unix/vi.html

A mí desde mi Terminal de Mac me deja copiar/pegar en modo edición, con el ratón eso sí. Creo que en Windows y con putty también se puede, estando en modo edición, hacer clic con el botón derecho del ratón y pegar. Esto lo digo porque se puede seleccionar lo que yo digo y pegar dentro.

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  berdini el Mar Ene 31, 2012 5:14 pm

Fuser escribió:
GRacias Fuser, ya estoy más cerca, no existía el directorio y lo he creado, ahora en el log aparece el problema que habías comentado. He de editar el starthddservices.sh para añadir las líneas de comandos que comentas pero no sé cómo hacerlo. He probado con el editor vi pero no me aparece todos los comandos que posteas más arriba, sólo las primeras líneas.

Venga, vamos con el cursillo de vi. Luego, si eso, ya postearé en un tema más general, o que nos lo muevan los moderadores... Smile


GRacias de nuevo. He realizado todos los pasos, ahora el starthddservices.sh no me da error pero el HDD log dice HDD not ready after 240 seconds! Voy a formatearlo desde el LG y lo volveré a intentar. Ya os contaré

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Fuser el Mar Ene 31, 2012 6:24 pm

berdini escribió:
GRacias de nuevo. He realizado todos los pasos, ahora el starthddservices.sh no me da error pero el HDD log dice HDD not ready after 240 seconds! Voy a formatearlo desde el LG y lo volveré a intentar. Ya os contaré

Ya te digo, yo diría que lo que no existe es el directorio /tmp/IMSMETA. Es que no estoy en casa para comprobarlo. ¿Has visto si lo tenías?

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  berdini el Mar Ene 31, 2012 7:43 pm

Solucionado, gracias mil Fuser. He utilizado tu sh y ya ha aparecido la carpeta CUSTOM en /tmp/hdd/root/custom/var/www/lgmenu/ y puedo acceder mediante WEB.

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Fallo en Torrent resuelto (mas o menos)

Mensaje  telepac el Miér Feb 01, 2012 8:06 pm

telepac escribió:Hola,

Ante todo felicidades por el gran trabajo realizado. La verdad es que he tenido la versión anterior y me iba genial sobre todo en mi caso para el FTP y el Torrent. Decidí cambiar a esta versión pero me falla el torrent, no se si le pasará a alguien más. En una de las versiones anteriores leí que a alguien le fallaba también y que se solucionaba poniendo el DNS correcto y/o actualizando el PM pero en mi caso eso es correcto. El primer sintoma era que no conseguia añadir ningún torrent, al final accediendo directamente al transmission usando el puerto 9091 conseguí que funcionara pero al añadir el torrent me aparece un error "Error: Unable to save resume file: No such file or directory". He leido en algún foro que puede ser un tema de permisos y que se soluciona pasandole en el arranque del demonio los directorios de configuracion y de descargas. ¿Hay alguien más con este problema?.



Un saludo.

Bueno, me respondo yo mismo por si a alguien le sirve de ayuda.

Creo que el problema estaba en que tenia un segundo disco duro metido y no se porque parece que se iba a ese disco a la hora de escribir. En cualquier caso he reinstalado todo de nuevo, borrado el directorio custom, usado las modificaciones que indicaba Fuser pues no podia crearlo otra vez con el starthddservices.sh, y parece que ahora funciona. Eso si, tengo que acceder por el puerto 9091 porque si no no sube el ficherro .torrent. No es mucho problema, pones 192.168.1.10:9091 (o la Ip que tenga tu equipo) en el navegador y listo.

bounce

telepac

Mensajes : 5
Fecha de inscripción : 20/07/2010

Ver perfil de usuario

Volver arriba Ir abajo

Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012) - Página 2 Empty Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 1 de 5. 1, 2, 3, 4, 5  Siguiente

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.