Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Página 2 de 5. Precedente  1, 2, 3, 4, 5  Siguiente

Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  ruanorecords el Mar Ene 24, 2012 6:17 pm

vic1972 escribió:Hola,
como se te dan los comandos por telnet en linux ?

yo lo que haria es borrar /tmp/hdd/root/custom
y lanzar de nuevo la instalacion ejecutando
/usr/local/etc/starthdservices.sh

y ver el log /tmp/hddservice.log
suerte

Bufff... La verdad que Linux un poco mal... Tengo Windows y Mac instalados... Y en un portatil "Netbook" tengo instalado Ubuntu... Si me comentas mas o menos paso a paso como hacerlo o si está escrito ya en el foro, ya que en eso soy totalmente principiante. Te lo agaradezco de verdad!

Saludos y Muchas Gracias!

ruanorecords

Mensajes : 3
Fecha de inscripción : 13/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Exactamente el mismo problema

Mensaje  berdini el Mar Ene 24, 2012 10:03 pm

Lo dicho en el titulo tengo EXACTAMENTE el mismo problema que ruanorecords (y ya lo he tenido con la version anterior del firmware). He probado con distintos pen y nada. No he realizado el Telnet pero sí he formateado el disco duro para eliminar cualquier carpeta y comenzar de cero pero tampoco he podido. Yo tengo el 400.

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

No puedo acceder desde LG menu

Mensaje  amperio el Miér Ene 25, 2012 1:08 am

Gracias por el aporte de Harmony. Se me ha instalado bien la primera parte, pero cuando intento acceder al LG (en mi caso http://192.168.0.102/) desde el navegador (Google Chrome), éste no la localiza y dice "esta web no está disponible". El caso es que el LG me reconoce la red, puedo acceder al You Tube, y puedo ver las películas que tengo almacenadas en un disco de red. No sé si es que no se me habrá instalado el LG menú. NOTA: Sí puedo acceder a él con el Administrador web que tenía previamente instalado. ¿Qué pasará?

amperio

Mensajes : 13
Fecha de inscripción : 30/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

Seinto decir que yo tambien tengo problemas con la ultima parte de la instalación.

Mensaje  rtc el Miér Ene 25, 2012 7:21 am

El último reinicio no lo hace y no aparece el servidor web. En cambio, el servidor de telnet sí está operativo. Contenta al ping t permite entrar por telner.
Ahora probaré las secuencias qe habeis comentado anteriomente.

En cuanto a Linux o windows... me gusta más el telnet de linux, pero desde windows también se puede hacer.

desde \windows\system32 podeis ejecuar el telnet igual que si estuvieseis en linux.

Ya os comentaré como van los avances!
Saludos y gracias por el curro que os habeis pegado y la información que nos dais...


rtc

Mensajes : 2
Fecha de inscripción : 02/01/2011

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  amperio el Miér Ene 25, 2012 10:26 am

Sin embargol el ping desde un ordenador de la red es correcto:

amperio

Mensajes : 13
Fecha de inscripción : 30/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

buscando el error...

Mensaje  rtc el Miér Ene 25, 2012 1:35 pm

Siguiendo las instrucciones me da los siguientes mensajes...

root@Venus:~# cd /tmp/hdd
root@Venus:/tmp/hdd# cd root
root@Venus:~# ls
backup lost+found


root@Venus:~# l
total 15
drwxrwxrwx 4 root root 1024 Jan 25 11:20 .
drwxr-xr-x 7 500 500 0 Dec 18 16:35 ..
-rw------- 1 root root 50 Jan 25 11:21 .ash_history
drwxr-xr-x 2 root root 1024 Jan 25 01:49 backup
y el fichero lost+found que no me ha salido en el volccado, pero no hay ni fichero ni directorio custom

root@Venus:~# /usr/local/etc/starthddservices.sh
swapon: /dev/scsi/host0/bus0/target0/lun0/part2: Device or resource busy
/usr/local/etc/starthddservice.sh: line 107: ./performUpdate.sh not found

el contenido de /tmp/hddservice.log:
2012-01-25 11:17:17 : Checking HDD presence...
2012-01-25 11:17:36 : HDD is ready after 18 seconds.
2012-01-25 11:17:38 : waiting for USB: 27s
2012-01-25 11:18:05 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:18:10 : Unpacking installation package...
2012-01-25 11:21:51 : Checking HDD presence...
2012-01-25 11:21:51 : HDD is ready after 0 seconds.
2012-01-25 11:21:53 : waiting for USB: 45s
2012-01-25 11:22:38 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:22:41 : Unpacking installation package...

Parece que no encuentra el fichero performUpdate.sh

Quizás lo he ejecutado desde un directorio incorrecto y por eso no lo encuentra....

Espero que alguien tenga alguna idea... thnx!

rtc

Mensajes : 2
Fecha de inscripción : 02/01/2011

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  JBL el Sáb Ene 28, 2012 9:07 pm

Hola foreros, uno que ha dado marcha atras, el wifi lo pierde al poco de iniciar el cacharrin y esto no me pasa con el anterior, graro, graro...

Un Saludote.

JBL

Mensajes : 130
Fecha de inscripción : 06/09/2010
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Instalación del Custom

Mensaje  Fuser el Dom Ene 29, 2012 3:14 pm

Hola,

quisiera aportar mi granito de arena.

Al igual que a algunos compañeros a mí tampoco se me instalaba el custom. Yo tenía el anterior firmware y custom, después realicé una instalación del firmware oficial y ahora había vuelto a poner el firmware 1.4 pero no me reiniciaba el aparato tras el primer INIT.

Bueno, mirando, mirando, he visto que el starthddservice.sh descomprimía el fichero custom en un directorio temporal, pero creando un nuevo directorio al cual al final no accedía, intentaba ejecutar performUpdate.sh desde el directorio padre.

NOTA > No os olvidéis de hacer copia de seguridad del starthddservice original:
cp /usr/local/etc/starthddservices.sh /usr/local/etc/starthddservices.sh.ORIG

Así pues he modificado el instalador starthddservice.sh de la siguiente forma (en negrita los cambios):
--------
Fichero /usr/local/etc/starthddservices.sh
Editar/cambiar/copiar y pegar desde la siguiente línea de guiones
---------------------------
#!/bin/sh

count=0
hddready=0
checkusb=1
maxusbwait=45

MAX_COUNT=240
HDDSERVICELOG=/tmp/hddservice.log
CHECKDIR=/tmp/IMSMETA
INSTPACKAGE="Custom-KV-v*.tar.gz"
INSTDIRECTORY="Custom-KV-v*"
TGTEMP=/tmp/hddmedia/lg/installation
CUSTOMHOME=/tmp/hdd/root/custom

SWAP1=/dev/scsi/host0/bus0/target0/lun0/part2
SWAP2=/dev/scsi/host1/bus0/target0/lun0/part2

timestamp() {
date "+%Y-%m-%d %H:%M:%S"
}

# Check HDD presence
echo `timestamp`" : Checking HDD presence..." >> $HDDSERVICELOG
while true; do
if [ -d $CHECKDIR ]; then
hddready=1
break
fi
count=$((count + 1))
if [ $count -eq $MAX_COUNT ]; then
hddready=0
break
fi
sleep 1
done

if [ $hddready -eq 0 ]; then
# The disk is not detected
echo `timestamp`" : HDD not ready after $count seconds!" >> $HDDSERVICELOG
else
# HDD is ready, so start all services
echo `timestamp`" : HDD is ready after $count seconds." >> $HDDSERVICELOG
sleep 2
/bin/mkdir -p /tmp/empty
/bin/mkdir -p /tmp/run

# Join swap
if [ -b $SWAP1 ]; then
/sbin/swapon -p 1 $SWAP1
fi
if [ -b $SWAP2 ]; then
/sbin/swapon -p 1 $SWAP2
fi

# Make a backup directory
mkdir -p /tmp/hdd/root/backup

if [ $count -lt $maxusbwait ]; then
sleeptime=$((maxusbwait - count));
echo `timestamp`" : waiting for USB: "$sleeptime"s" >> $HDDSERVICELOG
sleep $sleeptime
fi

# Check the USB presence
if [ ${checkusb} -eq 1 ]; then
for usbmount in `ls /tmp/usbmounts/`; do
packages=`ls /tmp/usbmounts/${usbmount}/${INSTPACKAGE}`
for p in ${packages}; do
echo `timestamp`" : Accessing installation package $p" >> $HDDSERVICELOG
# Create and clean temporary place
rm -fr $TGTEMP >/dev/null 2>/dev/null
mkdir -p $TGTEMP
cp ${p} $TGTEMP
cd $TGTEMP
echo `timestamp`" : Unpacking installation package..." >> $HDDSERVICELOG
gunzip -c `basename ${p}` | tar xf -
# Borramos fichero comprimido
rm -rf ${INSTPACKAGE}
# Accedemos al directorio donde estan los archivos
cd ${INSTDIRECTORY}
# Run update script from package
echo `timestamp`" : Directorio activo: "`pwd` >> $HDDSERVICELOG

./performUpdate.sh >> $HDDSERVICELOG
done
done
fi

# Start all init scripts in /etc/init.d
# executing them in numerical order.
if [ -d "$CUSTOMHOME" ]; then
for i in $CUSTOMHOME/etc/init.d/S??* ;do
# Ignore dangling symlinks (if any).
[ ! -f "$i" ] && continue

case "$i" in
*.sh)
# Source shell script for speed.
(
trap - INT QUIT TSTP
set start
. $i
)
;;
*)
# No sh extension, make sequential starting
$i start
;;
esac
done
fi
fi
#Copiar hasta aquí
# Fin del archivo
------------------------------------------------

Espero haberos sido de ayuda, si alguien no sabe cómo editar el fichero desde terminal, ya le daré un par de claves para usar vi, Smile

Salu2

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Fallo en Torrent

Mensaje  telepac el Dom Ene 29, 2012 11:58 pm

Hola,

Ante todo felicidades por el gran trabajo realizado. La verdad es que he tenido la versión anterior y me iba genial sobre todo en mi caso para el FTP y el Torrent. Decidí cambiar a esta versión pero me falla el torrent, no se si le pasará a alguien más. En una de las versiones anteriores leí que a alguien le fallaba también y que se solucionaba poniendo el DNS correcto y/o actualizando el PM pero en mi caso eso es correcto. El primer sintoma era que no conseguia añadir ningún torrent, al final accediendo directamente al transmission usando el puerto 9091 conseguí que funcionara pero al añadir el torrent me aparece un error "Error: Unable to save resume file: No such file or directory". He leido en algún foro que puede ser un tema de permisos y que se soluciona pasandole en el arranque del demonio los directorios de configuracion y de descargas. ¿Hay alguien más con este problema?.



Un saludo.


Última edición por telepac el Miér Feb 01, 2012 7:58 pm, editado 1 vez

telepac

Mensajes : 5
Fecha de inscripción : 20/07/2010

Ver perfil de usuario

Volver arriba Ir abajo

RE: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  gizbo84 el Lun Ene 30, 2012 1:22 pm

Antes de todo muchas gracias por este gran aporte!!!!!

He actualizado con el método 1 y no he tenido ningún problema durante la instalación pero no me puedo conectar mediante el menú web. No tengo problemas de conectividad, llego por ping y Telnet. ¿hay que configurar o activar algo más? ¿Cómo puedo comprovar si se ha instalado correctamente?

gizbo84

Mensajes : 11
Fecha de inscripción : 27/06/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Fuser el Lun Ene 30, 2012 1:52 pm

gizbo84 escribió:Antes de todo muchas gracias por este gran aporte!!!!!

He actualizado con el método 1 y no he tenido ningún problema durante la instalación pero no me puedo conectar mediante el menú web. No tengo problemas de conectividad, llego por ping y Telnet. ¿hay que configurar o activar algo más? ¿Cómo puedo comprovar si se ha instalado correctamente?

Hola,

¿te ha hecho un segundo reinicio después de entrar por primera vez en el INIT?

Tal vez te pase lo que al forero rtc y a mí... ¿Has visto mi respuesta un par de posts más arriba?

Tienes que entrar por telnet y luego teclear la siguiente línea, tal cual, para que ejecute la instalación de custom, creo que ahí es donde se coloca la web:
/usr/local/etc/starthddservices.sh

Si te va bien, el LG se te reiniciará cuando acabe el proceso. Si no, una vez lo tengas hecho, mira a ver si te sale algo similar a lo que decía rtc con el comando:
cat /tmp/hddservice.log


el contenido de /tmp/hddservice.log:
2012-01-25 11:17:17 : Checking HDD presence...
2012-01-25 11:17:36 : HDD is ready after 18 seconds.
2012-01-25 11:17:38 : waiting for USB: 27s
2012-01-25 11:18:05 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:18:10 : Unpacking installation package...
2012-01-25 11:21:51 : Checking HDD presence...
2012-01-25 11:21:51 : HDD is ready after 0 seconds.
2012-01-25 11:21:53 : waiting for USB: 45s
2012-01-25 11:22:38 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:22:41 : Unpacking installation package...

Parece que no encuentra el fichero performUpdate.sh

Sigue entonces la modificación del fichero que posteé ayer.

Ah y no te olvides de volver a ejectuar starthddservices.sh otra vez!! Smile

Un saludo,

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  berdini el Mar Ene 31, 2012 12:00 am

ruanorecords escribió:
vic1972 escribió:Hola,
como se te dan los comandos por telnet en linux ?

yo lo que haria es borrar /tmp/hdd/root/custom
y lanzar de nuevo la instalacion ejecutando
/usr/local/etc/starthdservices.sh

y ver el log /tmp/hddservice.log
suerte

Bufff... La verdad que Linux un poco mal... Tengo Windows y Mac instalados... Y en un portatil "Netbook" tengo instalado Ubuntu... Si me comentas mas o menos paso a paso como hacerlo o si está escrito ya en el foro, ya que en eso soy totalmente principiante. Te lo agaradezco de verdad!

Saludos y Muchas Gracias!

despues del Telnet...

el contenido de /tmp/hddservice.log:
2012-01-30 21:50:13 : Checking HDD presence...
2012-01-30 21:54:16 : HDD not ready after 240 seconds!


No lo entiendo pq el HDD nunque me ha dado ningún problema. (Tengo el LG 400)

Además no existe la carpeta custom en /tmp/hdd/root/ sólo aparecen lock y recovery

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  gizbo84 el Mar Ene 31, 2012 12:44 am

Fuser escribió:
gizbo84 escribió:Antes de todo muchas gracias por este gran aporte!!!!!

He actualizado con el método 1 y no he tenido ningún problema durante la instalación pero no me puedo conectar mediante el menú web. No tengo problemas de conectividad, llego por ping y Telnet. ¿hay que configurar o activar algo más? ¿Cómo puedo comprovar si se ha instalado correctamente?

Hola,

¿te ha hecho un segundo reinicio después de entrar por primera vez en el INIT?

Tal vez te pase lo que al forero rtc y a mí... ¿Has visto mi respuesta un par de posts más arriba?

Tienes que entrar por telnet y luego teclear la siguiente línea, tal cual, para que ejecute la instalación de custom, creo que ahí es donde se coloca la web:
/usr/local/etc/starthddservices.sh

Si te va bien, el LG se te reiniciará cuando acabe el proceso. Si no, una vez lo tengas hecho, mira a ver si te sale algo similar a lo que decía rtc con el comando:
cat /tmp/hddservice.log


el contenido de /tmp/hddservice.log:
2012-01-25 11:17:17 : Checking HDD presence...
2012-01-25 11:17:36 : HDD is ready after 18 seconds.
2012-01-25 11:17:38 : waiting for USB: 27s
2012-01-25 11:18:05 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:18:10 : Unpacking installation package...
2012-01-25 11:21:51 : Checking HDD presence...
2012-01-25 11:21:51 : HDD is ready after 0 seconds.
2012-01-25 11:21:53 : waiting for USB: 45s
2012-01-25 11:22:38 : Accessing installation package /tmp/usbmounts/sdb1/Custom
-KV-v108-IV.tar.gz
2012-01-25 11:22:41 : Unpacking installation package...

Parece que no encuentra el fichero performUpdate.sh

Sigue entonces la modificación del fichero que posteé ayer.

Ah y no te olvides de volver a ejectuar starthddservices.sh otra vez!! Smile

Un saludo,


Muchas Gracias Fuser!!! Lo he solucionado con tu post anterior.

gizbo84

Mensajes : 11
Fecha de inscripción : 27/06/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Fuser el Mar Ene 31, 2012 10:15 am

berdini escribió:
ruanorecords escribió:
vic1972 escribió:Hola,
como se te dan los comandos por telnet en linux ?

yo lo que haria es borrar /tmp/hdd/root/custom
y lanzar de nuevo la instalacion ejecutando
/usr/local/etc/starthdservices.sh

y ver el log /tmp/hddservice.log
suerte

Bufff... La verdad que Linux un poco mal... Tengo Windows y Mac instalados... Y en un portatil "Netbook" tengo instalado Ubuntu... Si me comentas mas o menos paso a paso como hacerlo o si está escrito ya en el foro, ya que en eso soy totalmente principiante. Te lo agaradezco de verdad!

Saludos y Muchas Gracias!

despues del Telnet...

el contenido de /tmp/hddservice.log:
2012-01-30 21:50:13 : Checking HDD presence...
2012-01-30 21:54:16 : HDD not ready after 240 seconds!


No lo entiendo pq el HDD nunque me ha dado ningún problema. (Tengo el LG 400)

Además no existe la carpeta custom en /tmp/hdd/root/ sólo aparecen lock y recovery

Hola Berdini,

igual es que no tienes el directorio /tmp/IMSMETA creado...

Compruébalo siguiendo éstos pasos:
1. Entra por telnet o ssh.

2. escribe:
ls /tmp/IMS*

si te sale IMSMETA, habrá que ver si es un directorio. Si no te sale, créalo con:

mkdir /tmp/IMSMETA

3. ejecuta:
/usr/local/etc/starthdservices.sh

4. Si se te reinicia el LG cuando acabe, perfecto. Si no, envíanos el log.

Un saludo,

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  berdini el Mar Ene 31, 2012 12:52 pm

Fuser escribió:

Hola Berdini,

igual es que no tienes el directorio /tmp/IMSMETA creado...

Compruébalo siguiendo éstos pasos:
1. Entra por telnet o ssh.

2. escribe:
ls /tmp/IMS*

si te sale IMSMETA, habrá que ver si es un directorio. Si no te sale, créalo con:

mkdir /tmp/IMSMETA

3. ejecuta:
/usr/local/etc/starthdservices.sh

4. Si se te reinicia el LG cuando acabe, perfecto. Si no, envíanos el log.

Un saludo,

GRacias Fuser, ya estoy más cerca, no existía el directorio y lo he creado, ahora en el log aparece el problema que habías comentado. He de editar el starthddservices.sh para añadir las líneas de comandos que comentas pero no sé cómo hacerlo. He probado con el editor vi pero no me aparece todos los comandos que posteas más arriba, sólo las primeras líneas.

Muchas gracias!

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Cursillo de vi

Mensaje  Fuser el Mar Ene 31, 2012 3:00 pm

GRacias Fuser, ya estoy más cerca, no existía el directorio y lo he creado, ahora en el log aparece el problema que habías comentado. He de editar el starthddservices.sh para añadir las líneas de comandos que comentas pero no sé cómo hacerlo. He probado con el editor vi pero no me aparece todos los comandos que posteas más arriba, sólo las primeras líneas.

Venga, vamos con el cursillo de vi. Luego, si eso, ya postearé en un tema más general, o que nos lo muevan los moderadores... Smile

Como medida de precaución, haremos copia de seguridad del fichero en cuestión:
cp /usr/local/etc/starthddservices.sh /usr/local/etc/starthddservices.sh.ORIG

Entramos en el editor vi:
vi /usr/local/etc/starthddservices.sh

Vi tiene dos modos: Edición y movimiento del cursor e introducción de otros comandos. Nada más entrar y ver el contenido del fichero, estamos en modo "Movimiento".

Para mover el cursor, se utilizan las flechas arriba, abajo izquierda y derecha, pero si éstas no van las teclas que funcionan son:
h Izquierda
j Abajo
k Arriba
l Derecha

Si queremos editar un texto pulsamos:
i - Para insertar nuevos caracteres a partir de la posición actual.
a - Para añadir nuevos caracteres a partir de la posición actual.
A - (en mayúscula) para añadir nuevos caracteres a final de línea.

Por ejemplo, si queremos añadir una nueva línea, estando en modo "Movimiento" hacemos lo siguiente:
- ir al comienzo de una línea, a partir de la cual añadiremos las nuevas.
- Pulsar A (abajo aparecerá INSERT para indicar que estamos en modo edición)
- Intro, para crear y pasar a una nueva línea.
- Escribiremos lo que queramos.
- ESC para salir del modo edición.

Para guardar los cambios, cuando estemos en modo "Movimiento", (Muy importante):
: (irá a la parte inferior del fichero)
w (para guardar)
Intro para hacer efectivo el comando.

Si no queremos guardar:
:
q (indica que queremos salir)
! (Indica que no queremos guardar)
Intro

Si queremos guardar y salir, todo a la vez:
:
w
q
Intro

Info ampliada:
http://www.washington.edu/computing/unix/vi.html

A mí desde mi Terminal de Mac me deja copiar/pegar en modo edición, con el ratón eso sí. Creo que en Windows y con putty también se puede, estando en modo edición, hacer clic con el botón derecho del ratón y pegar. Esto lo digo porque se puede seleccionar lo que yo digo y pegar dentro.

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  berdini el Mar Ene 31, 2012 5:14 pm

Fuser escribió:
GRacias Fuser, ya estoy más cerca, no existía el directorio y lo he creado, ahora en el log aparece el problema que habías comentado. He de editar el starthddservices.sh para añadir las líneas de comandos que comentas pero no sé cómo hacerlo. He probado con el editor vi pero no me aparece todos los comandos que posteas más arriba, sólo las primeras líneas.

Venga, vamos con el cursillo de vi. Luego, si eso, ya postearé en un tema más general, o que nos lo muevan los moderadores... Smile


GRacias de nuevo. He realizado todos los pasos, ahora el starthddservices.sh no me da error pero el HDD log dice HDD not ready after 240 seconds! Voy a formatearlo desde el LG y lo volveré a intentar. Ya os contaré

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Fuser el Mar Ene 31, 2012 6:24 pm

berdini escribió:
GRacias de nuevo. He realizado todos los pasos, ahora el starthddservices.sh no me da error pero el HDD log dice HDD not ready after 240 seconds! Voy a formatearlo desde el LG y lo volveré a intentar. Ya os contaré

Ya te digo, yo diría que lo que no existe es el directorio /tmp/IMSMETA. Es que no estoy en casa para comprobarlo. ¿Has visto si lo tenías?

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  berdini el Mar Ene 31, 2012 7:43 pm

Solucionado, gracias mil Fuser. He utilizado tu sh y ya ha aparecido la carpeta CUSTOM en /tmp/hdd/root/custom/var/www/lgmenu/ y puedo acceder mediante WEB.

berdini

Mensajes : 26
Fecha de inscripción : 22/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Fallo en Torrent resuelto (mas o menos)

Mensaje  telepac el Miér Feb 01, 2012 8:06 pm

telepac escribió:Hola,

Ante todo felicidades por el gran trabajo realizado. La verdad es que he tenido la versión anterior y me iba genial sobre todo en mi caso para el FTP y el Torrent. Decidí cambiar a esta versión pero me falla el torrent, no se si le pasará a alguien más. En una de las versiones anteriores leí que a alguien le fallaba también y que se solucionaba poniendo el DNS correcto y/o actualizando el PM pero en mi caso eso es correcto. El primer sintoma era que no conseguia añadir ningún torrent, al final accediendo directamente al transmission usando el puerto 9091 conseguí que funcionara pero al añadir el torrent me aparece un error "Error: Unable to save resume file: No such file or directory". He leido en algún foro que puede ser un tema de permisos y que se soluciona pasandole en el arranque del demonio los directorios de configuracion y de descargas. ¿Hay alguien más con este problema?.



Un saludo.

Bueno, me respondo yo mismo por si a alguien le sirve de ayuda.

Creo que el problema estaba en que tenia un segundo disco duro metido y no se porque parece que se iba a ese disco a la hora de escribir. En cualquier caso he reinstalado todo de nuevo, borrado el directorio custom, usado las modificaciones que indicaba Fuser pues no podia crearlo otra vez con el starthddservices.sh, y parece que ahora funciona. Eso si, tengo que acceder por el puerto 9091 porque si no no sube el ficherro .torrent. No es mucho problema, pones 192.168.1.10:9091 (o la Ip que tenga tu equipo) en el navegador y listo.

bounce

telepac

Mensajes : 5
Fecha de inscripción : 20/07/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  amperio el Miér Feb 01, 2012 10:48 pm

No consigo instalar el lg menu. He seguido algunos pasos indicados, entre ellos intentar reejecutar desde telnet starthddservices.sh, pero me dice que está ocupado. Tampoco veo el directorio Custom, si es que tiene que verse. A ver si me podeis echar una mano.


root@Venus:~# ls /tmp/IMS*
/tmp/IMS:
REC image lg lgms400 movie music

/tmp/IMSMETA:
CheckFEInfoCmd.fec first_request_64encode
CheckFEInfoCmd.fec.decode lost+found
backup second_request
first_request second_request_64encode
root@Venus:~# /usr/local/etc/starthddservices.sh
swapon: /dev/scsi/host0/bus0/target0/lun0/part2: Device or resource busy

root@Venus:~# cd /tmp/hdd
root@Venus:/tmp/hdd# cd root
root@Venus:~# ls
CheckFEInfoCmd.fec first_request_64encode
CheckFEInfoCmd.fec.decode lost+found
backup second_request
first_request second_request_64encode
root@Venus:~# l
total 21
drwxrwxrwx 5 root root 1024 Jan 24 22:32 .
drwxr-xr-x 7 500 500 0 Dec 18 16:35 ..
-rw------- 1 root root 1549 Feb 1 20:15 .ash_history
drwxr-xr-x 2 root root 1024 Apr 9 2011 .console
-rw-r--r-- 1 root root 0 Nov 20 11:02 CheckFEInfoCmd.fec
-rw-r--r-- 1 root root 0 Dec 1 15:06 CheckFEInfoCmd.fec.deco
de
drwxr-xr-x 2 root root 1024 Jan 24 22:16 backup
-rw-r--r-- 1 root root 270 Nov 20 11:02 first_request
-rw-r--r-- 1 root root 365 Nov 20 11:02 first_request_64encode
drwx------ 2 root root 12288 Apr 2 2011 lost+found
-rw-r--r-- 1 root root 271 Sep 17 14:49 second_request
-rw-r--r-- 1 root root 369 Sep 17 14:49 second_request_64encode

amperio

Mensajes : 13
Fecha de inscripción : 30/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Fuser el Jue Feb 02, 2012 6:13 pm

amperio escribió:No consigo instalar el lg menu. He seguido algunos pasos indicados, entre ellos intentar reejecutar desde telnet starthddservices.sh, pero me dice que está ocupado. Tampoco veo el directorio Custom, si es que tiene que verse. A ver si me podeis echar una mano.

Hola Amperio,

¿puedes pasar el log que se encuentra en /tmp? Revisa los mensajes anteriores porque creo que estás en la misma situación que otros compañeros.

Un saludo,

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Fuser el Jue Feb 02, 2012 6:24 pm

telepac escribió:

Bueno, me respondo yo mismo por si a alguien le sirve de ayuda.

Creo que el problema estaba en que tenia un segundo disco duro metido y no se porque parece que se iba a ese disco a la hora de escribir. En cualquier caso he reinstalado todo de nuevo, borrado el directorio custom, usado las modificaciones que indicaba Fuser pues no podia crearlo otra vez con el starthddservices.sh, y parece que ahora funciona. Eso si, tengo que acceder por el puerto 9091 porque si no no sube el ficherro .torrent. No es mucho problema, pones 192.168.1.10:9091 (o la Ip que tenga tu equipo) en el navegador y listo.

bounce

Nas telepac,

no acabo de comprender cuál es tu incidencia. Yo he podido activar el servicio Torrent. Luego desde la misma web del LG, accedo al apartado Torrents y para cargar una semilla .torrent nada más tengo que examinar mi equipo, pero para serte sincero no le he subido ninguna, así que tampoco puedo confirmarte al 100% que a mí me funcione correcto.

Un saludo,

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  amperio el Jue Feb 02, 2012 7:12 pm

Fuser escribió:
amperio escribió:No consigo instalar el lg menu. He seguido algunos pasos indicados, entre ellos intentar reejecutar desde telnet starthddservices.sh, pero me dice que está ocupado. Tampoco veo el directorio Custom, si es que tiene que verse. A ver si me podeis echar una mano.

Hola Amperio,

¿puedes pasar el log que se encuentra en /tmp? Revisa los mensajes anteriores porque creo que estás en la misma situación que otros compañeros.

Un saludo,

Te refieres a esto?:

root@Venus:/tmp# l
total 21
drwxrwxrwt 14 root root 0 Feb 2 14:37 .
drwxr-xr-x 13 root root 158 Dec 9 2009 ..
lrwxrwxrwx 1 root root 31 Feb 2 14:37 IMS -> /usr/local/etc/hdd/volumes/HDD1
lrwxrwxrwx 1 root root 23 Feb 2 14:37 IMSMETA -> /usr/local/etc/hdd/root
-rw-r--r-- 1 root root 3 Feb 2 14:37 PM_version
-rw-r--r-- 1 root root 5777 Feb 2 16:24 PipeManagement.log
prw-rw-rw- 1 root root 0 Feb 2 16:59 appout
-rw-r--r-- 1 root root 2 Feb 2 14:37 command_sender.txt
drwxr-xr-x 2 root root 0 Feb 2 14:37 empty
drwxr-xr-x 7 500 500 0 Dec 18 16:35 hdd
lrwxrwxrwx 1 root root 31 Feb 2 14:37 hddmedia -> /usr/local/etc/hdd/volumes/HDD1
-rw-r--r-- 1 root root 297 Feb 2 14:37 hddservice.log
drwxr-xr-x 3 root root 0 Nov 18 2009 lib
drwxr-xr-x 4 root root 0 Feb 2 14:37 lock
drwxr-xr-x 3 root root 0 Nov 18 2009 log
drwxr-xr-x 2 root root 0 Feb 2 14:37 net
drwxr-xr-x 3 root root 0 Feb 2 14:37 netb
drwxr-xr-x 6 root root 0 Feb 2 16:24 ramfs
drwxr-xr-x 2 root root 0 Feb 2 14:37 run
drwxr-xr-x 2 root root 0 Feb 2 14:37 smb
drwxr-xr-x 3 root root 0 Nov 18 2009 usbmounts
drwxr-xr-x 4 root root 0 Nov 18 2009 www
root@Venus:/tmp#

amperio

Mensajes : 13
Fecha de inscripción : 30/10/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Fuser el Jue Feb 02, 2012 7:16 pm

amperio escribió:
Fuser escribió:
amperio escribió:No consigo instalar el lg menu. He seguido algunos pasos indicados, entre ellos intentar reejecutar desde telnet starthddservices.sh, pero me dice que está ocupado. Tampoco veo el directorio Custom, si es que tiene que verse. A ver si me podeis echar una mano.

Hola Amperio,

¿puedes pasar el log que se encuentra en /tmp? Revisa los mensajes anteriores porque creo que estás en la misma situación que otros compañeros.

Un saludo,

Te refieres a esto?:

root@Venus:/tmp# l
total 21
drwxrwxrwt 14 root root 0 Feb 2 14:37 .
drwxr-xr-x 13 root root 158 Dec 9 2009 ..
lrwxrwxrwx 1 root root 31 Feb 2 14:37 IMS -> /usr/local/etc/hdd/volumes/HDD1
lrwxrwxrwx 1 root root 23 Feb 2 14:37 IMSMETA -> /usr/local/etc/hdd/root
-rw-r--r-- 1 root root 3 Feb 2 14:37 PM_version
-rw-r--r-- 1 root root 5777 Feb 2 16:24 PipeManagement.log
prw-rw-rw- 1 root root 0 Feb 2 16:59 appout
-rw-r--r-- 1 root root 2 Feb 2 14:37 command_sender.txt
drwxr-xr-x 2 root root 0 Feb 2 14:37 empty
drwxr-xr-x 7 500 500 0 Dec 18 16:35 hdd
lrwxrwxrwx 1 root root 31 Feb 2 14:37 hddmedia -> /usr/local/etc/hdd/volumes/HDD1
-rw-r--r-- 1 root root 297 Feb 2 14:37 hddservice.log
drwxr-xr-x 3 root root 0 Nov 18 2009 lib
drwxr-xr-x 4 root root 0 Feb 2 14:37 lock
drwxr-xr-x 3 root root 0 Nov 18 2009 log
drwxr-xr-x 2 root root 0 Feb 2 14:37 net
drwxr-xr-x 3 root root 0 Feb 2 14:37 netb
drwxr-xr-x 6 root root 0 Feb 2 16:24 ramfs
drwxr-xr-x 2 root root 0 Feb 2 14:37 run
drwxr-xr-x 2 root root 0 Feb 2 14:37 smb
drwxr-xr-x 3 root root 0 Nov 18 2009 usbmounts
drwxr-xr-x 4 root root 0 Nov 18 2009 www
root@Venus:/tmp#

Más o menos... Smile

teclea la línea:
cat /tmp/hddservice.log

y luego nos posteas el resultado para ver dónde se queda la ejecución de starthddservices.sh

Un saludo,

Fuser

Mensajes : 20
Fecha de inscripción : 12/05/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Nuevo custom Firmware MSHarmony Pack v1.4 (Enero-2012)

Mensaje  Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 2 de 5. Precedente  1, 2, 3, 4, 5  Siguiente

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.