Servidor SAMBA

Página 1 de 5. 1, 2, 3, 4, 5  Siguiente

Ir abajo

Servidor SAMBA

Mensaje  Admin el Jue Dic 10, 2009 1:32 am

Bueno, pues funcionando ok samba en ms450h,
gracias a Yannjeg,Youpla, Seb@stien y al foro francés (merci Smile)

Como simpre, cuidado con los pasos, y no nos hacemos responsables de posibles daños.

Hilo de referencia: http://ms450h.forumactif.com/personnalisation-astuces-et-modding-f11/installer-samba-t14.htm



Bueno, ademas, el compañero pelutxin nos ha creado un tutorial para torpes en pdf, gracias,
dejo aqui el enlace:
megaupload.com 71U1KWC9




Pasos:
a. Nos situamos en la carpeta root.
Código:

cd /tmp/hdd/root
quedando el path: /tmp/hdd/root

b. Nos bajamos el archivo: http://youpla.bof.free.fr/ms400h/smbdYoupla.tar
Código:

wget http://youpla.bof.free.fr/ms400h/smbdYoupla.tar


c. Ahora a descomprimir.(Se crea automáticamente el directorio samba)
Código:

tar xvf smbdYoupla.tar

d. Podemos elegir servidor samba con autentificación de usuarios o sin autentificación,
a mi me resulta más cómodo sin autentificación,

e. Editamos con vi:
Código:
 cd smbd
vi rc.smbd
editamos, y descomentamos esta linea:
${SMBD_PATH}/smbd -D -s smb.conf
y comentamos la siguiente.

el contenido de mi archivo:
Código:
#!/bin/sh

# !!! CHANGE THIS TO THE RIGHT PATH !!!!
# ---------------------------------------------
SMBD_PATH=/usr/local/etc/hdd/root/samba/smbd
# ---------------------------------------------

stop() { 
        echo "Stop samba server..."
        killall smbd
        rm /var/samba
}

start() {
        echo "Start samba server..."

        # link /var/samba to smbd directory
        ln -s ${SMBD_PATH} /var/samba
       
        # start smbd
        ${SMBD_PATH}/smbd -D -s smb.conf        # Version sans mot de passe
        #${SMBD_PATH}/smbd -D -s smbuser.conf  # Version avec mot de passe
}

case "$1" in
        start)
                start;;   
        stop)
                stop;;
        restart)
                stop;start;;
        *)
                echo "smbd server usage:"
                echo "$0 [start] [stop] [restart]" 
                ;;
esac

f. El archivo principal de configuración de samba es smb.conf
lo editamos con
Código:
vi smb.conf
el contenido de mi archivo es:
Código:
[global]
netbios name=LGMS450
workgroup=INFORTEL
server string=LGMS450
security=share
interfaces=eth0 wlan0

log file = /var/samba/samba.log
lock directory = /var/samba/locks
pid directory = /var/samba/locks
private dir = /var/samba/private

smb passwd file=/var/samba/private/smbpasswd
encrypt passwords=true
null paswords=yes
guest account=root

# Disable everything that concerns printers
printcap name = /dev/null
load printers = no
printcap cache time = 0
disable spoolss = yes
show add printer wizard = no

[hdd]
path=/usr/local/etc/hdd/volumes
comment=HDD directory
public=yes
writeable=yes

[root]
path=/usr/local/etc/hdd/root
comment=Working directory
public=yes
writeable=yes

[timeshift]
path=/usr/local/etc/hdd/livepause
comment=Timeshift directory
public=yes

g. Ya queda tan sólo arrancar el demonio con:
Código:
/tmp/hdd/root/samba/smbd # ./rc.smbd  start
Start samba server...

h. Para comprobar que todo es correcto, vemos si los procesos están correctamente en
ejecucion con el comando ps,
en mi sistema muestra
449 root 540 S -sh
484 root 2156 S /usr/local/etc/hdd/root/samba/smbd/smbd -D -s smb.con
485 root 2140 S /usr/local/etc/hdd/root/samba/smbd/smbd -D -s smb.con
488 root 2652 S /usr/local/etc/hdd/root/samba/smbd/smbd -D -s smb.con


i. Y ya desde mi equipo puedo acceder a las carpetas compartidas del lg Smile SUPER
yo que trabajo en linux, con el comando smbclient aparecen los compartidos.
[victor@asus ~]$ smbclient -L 192.168.0.18
Enter victor's password:
Domain=[INFORTEL] OS=[Unix] Server=[Samba 3.0.23c]

Sharename Type Comment
--------- ---- -------
hdd Disk HDD directory
root Disk Working directory
timeshift Disk Timeshift directory
IPC$ IPC IPC Service (LGMS450)
Domain=[INFORTEL] OS=[Unix] Server=[Samba 3.0.23c]

Server Comment
--------- -------

Workgroup Master
--------- -------


Última edición por Admin el Miér Ene 20, 2010 10:04 am, editado 5 veces (Razón : Corrección de errores)

Admin
Admin

Mensajes : 70
Fecha de inscripción : 07/12/2009

Ver perfil de usuario http://ms450.forosactivos.net

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  Seb el Vie Dic 11, 2009 1:53 pm

Thanks to Yannjeg,Youpla, Seb@stien too Wink

Seb@stien

Seb
Invitado


Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  Admin el Vie Dic 11, 2009 2:08 pm

Edited!!
Merci mon ami.
amities

Admin
Admin

Mensajes : 70
Fecha de inscripción : 07/12/2009

Ver perfil de usuario http://ms450.forosactivos.net

Volver arriba Ir abajo

Tutorial para torpes

Mensaje  pelutxin el Miér Dic 23, 2009 1:55 pm

Hola, sigo desde hace tiempo el hilo del foro http://www.forodvd.com/showthread.php?t=75235 dicho foro me remitio a este, ya que yo lo que queria es conectar por Samba al LG, dispongo de un mac, un Pc con windows y no muchos conocimientos, asi que agradeceria si alguien podria "traducir" a lenguaje de torpe el tutorial colgado.
Sin mas, un saludo y gracias
Eduardo

pelutxin

Mensajes : 15
Fecha de inscripción : 23/12/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  Admin el Miér Dic 23, 2009 2:03 pm

Hola bienvenido Smile

Bueno, al principio de este post este explicado paso a paso.
Lo que pasa es que se requieren ciertos conocimientos, editar con vi, manejar telnet, etc

Lo que tenemos en mente es preparar firmwares modificados para cargarlo por USB y traiga todos los addons
que se han ido descubriendo. Esto requiere algo de tiempo, ya que modificar las cosas pueden ser peligrosas, y
entonces estamos avanzando poco a poco, Wink pero en la buena dirección.

Si quieres puedes ir intentando los pasos poco a poco, y escribes donde te pierdes.

saludos

Admin
Admin

Mensajes : 70
Fecha de inscripción : 07/12/2009

Ver perfil de usuario http://ms450.forosactivos.net

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  ev@ngel el Lun Dic 28, 2009 7:26 pm

Buenas...

He editado los scripts tal como los tuyos... sin problema (cambiando el workgroup claro) y después de ejecutar el...

/tmp/hdd/root/samba/smbd # ./rc.smbd start

me sale el siguiente error...

-sh: /tmp/hdd/root/samba/smbd: Permission denied

Estoy conectado por Putty y el usuario del Telnet es root... ¿que hago para tene permiso de ejecución? GRACIAS!!!
avatar
ev@ngel

Mensajes : 260
Fecha de inscripción : 20/12/2009
Edad : 43
Localización : Valladolid

Ver perfil de usuario

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  vic1972 el Lun Dic 28, 2009 7:31 pm

Hola,
para dar permisos de ejecucion al fichero es: chmod ugo+x nombre_fichero

por las dudas ejecuta: ls -l
antes y despues, nos pasteas el resultado

suerte
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  ev@ngel el Lun Dic 28, 2009 10:50 pm

Ya he venido del cumpleaños de los niños Very Happy ...vamos a ver...

Pues antes de ejecutar el chmod tenía...
-rwxr--r-- 1 root root 626 Dec 28 17:09 rc.smbd

Y después
-rwxr-xr-x 1 root root 626 Dec 28 17:09 rc.smbd

Y YA ESTA!!! aunque ha sido un poco raro... me encontraba ya en la ruta
/tmp/hdd/root/samba/smbd # y al ejecutar el...
"/tmp/hdd/root/samba/smbd # ./rc.smbd start" todo enterito (sin comillas claro) me ha vuelto a dar el problema de los permisos... a los 2-3 minutos desde la misma ubicación he ejecutado la "versión corta"...

./rc.smbd start y ... ya ha salido el mensaje de "Start samba server..." lo he provado y FUNCIONA CORRECTAMENTE!!! Gracias "Vic" ahora voy a por el cliente torrent... a ver si lo hago a la primera Very Happy
avatar
ev@ngel

Mensajes : 260
Fecha de inscripción : 20/12/2009
Edad : 43
Localización : Valladolid

Ver perfil de usuario

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  ev@ngel el Lun Dic 28, 2009 10:56 pm

Creo que me he dado cuente de "mi error"... se puede ver que controlo poco de Linux ¿verdad? en fin he estado 20 minutos para editar los scripts con el "vi" Shocked

Así que imagino que a lo mejor no era necesario ni modificar los permisos con el chmod, verdad?? Bueno dejaremos los permisos como están!!! Gracias de nuevo... la verdad es que ahora es comodisimo mover información entre los aparatos... cuando lo haga de forma automática será la bomba eh??
avatar
ev@ngel

Mensajes : 260
Fecha de inscripción : 20/12/2009
Edad : 43
Localización : Valladolid

Ver perfil de usuario

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  Admin el Lun Dic 28, 2009 11:10 pm

Si,
es muy comodo, entre otros usos, me encanta modificar los nombres de las grabaciones comodamente desde el pc usando el teclado.
A los dibujos de los niños los guardo con el titulo, asi me evito grabar episodios repetidos Smile

El arranque automatico esta parcialmente solucionado, pero estoy trabajando en una version mejor, ya lo pondre por aqui Smile

Admin
Admin

Mensajes : 70
Fecha de inscripción : 07/12/2009

Ver perfil de usuario http://ms450.forosactivos.net

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  ev@ngel el Lun Dic 28, 2009 11:18 pm

Gracias vic... yo ya tengo renombrados todos los capitulos del Lazy Town Very Happy Very Happy Very Happy que me tiene frito la niña todo el día con la serie... Razz Creo que me entiendes...
avatar
ev@ngel

Mensajes : 260
Fecha de inscripción : 20/12/2009
Edad : 43
Localización : Valladolid

Ver perfil de usuario

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  vic1972 el Mar Dic 29, 2009 11:10 am

Claro que te entiendo, en mi caso es con los doras (2 años) y gormitis (4 años)
JAJAJA Smile

Cada dia estamos mas contento con el producto este de LG.

Por cierto, algo raro que me esta ocrriendo, es que siempre que pongo disney channel, se pone por defecto
el sonido en idioma ingles, yo lo paso rapidamente a español dandole al boton.
Pero porque me ocurre esto?
os ocurre a vosotros?

saludos
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  ev@ngel el Mar Dic 29, 2009 12:49 pm

A mi no me ocurre eso con ese canal (ni con ningún otro... de momento), lo acabo de verificar... Shocked
avatar
ev@ngel

Mensajes : 260
Fecha de inscripción : 20/12/2009
Edad : 43
Localización : Valladolid

Ver perfil de usuario

Volver arriba Ir abajo

Rutas

Mensaje  Lino el Miér Dic 30, 2009 10:54 pm

He descargado y descomprimido el samba en la siguiente carpeta

tmp/hdd/root/samba/smbd/

¿Tengo que cambiar los archivos de configuración a estas dirección? ¿todas?

Gracias

Lino

Mensajes : 49
Fecha de inscripción : 29/12/2009
Localización : Valencia

Ver perfil de usuario http://twitter.com/moinelo

Volver arriba Ir abajo

¿es correcto?

Mensaje  Lino el Miér Dic 30, 2009 10:59 pm

Una vez he conseguido iniciar el samba, me sale lo siguiente con ps:

454 root 488 S -sh
477 root 304 S /tmp/hdd/root/ftp/bftpd -d -c ./bftpd.conf (esto es el servidor de ftp, lo único que he conseguido hacer funcionar)
494 root 2168 S /tmp/hdd/root/samba/smbd//smbd -d 1 -D -s /tmp/hdd/ro
497 root 2152 S /tmp/hdd/root/samba/smbd//smbd -d 1 -D -s /tmp/hdd/ro

no coincide con lo explicado, y me da mala espina ¿no?

Lino

Mensajes : 49
Fecha de inscripción : 29/12/2009
Localización : Valencia

Ver perfil de usuario http://twitter.com/moinelo

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  vic1972 el Miér Dic 30, 2009 10:59 pm

Hola,
te digo de memoria,
creo que si lo haces justo en esa ruta, no tienes que cambiar nada,
ya que si te fijas en los 2 archivos ya usa ese path.
buena suerte y cuidadin affraid

Wink saludos
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Lo dejo por hoy

Mensaje  Lino el Miér Dic 30, 2009 11:44 pm

He vuelto a descomprimir el samba para deshacer algunos cambios y he repetido el proceso, tras matar los procesos con kill <nº proceso> y ahora me sale esto:

544 root 484 S -sh
558 root 2164 S /usr/local/etc/hdd/root/samba/smbd/smbd -d 1 -D -s /u
559 root 2152 S /usr/local/etc/hdd/root/samba/smbd/smbd -d 1 -D -s /u

Pero sigue sin fucnionar Question Crying or Very sad

No entiendo lo de las rutas, estas no tienen nada que ver con la que he descargado el samba. No sé por tanto, si hay que hacer alguna modificación y cual, en smbd.conf o en rc.smbd

Disculpad mi torpeza y mi ignorancia Embarassed

Lino

Mensajes : 49
Fecha de inscripción : 29/12/2009
Localización : Valencia

Ver perfil de usuario http://twitter.com/moinelo

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  vic1972 el Jue Dic 31, 2009 12:39 am

Mis procesos aparecen como:
517 root 2140 S /usr/local/etc/hdd/root/samba/smbd/smbd -D -s smb.conf
521 root 2128 S /usr/local/etc/hdd/root/samba/smbd/smbd -D -s smb.conf

Animo, estas cerca.
Si quieres pon aqui todos los archivos, y paths.
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Perdón y gracias

Mensaje  Lino el Jue Dic 31, 2009 8:23 am

Acabo de darme cuenta de que la ruta SI es la misma, lo que pasa es que va a través de un acceso directo.

Vale, en cuanto retome esto, os comunico mi pequeño periplo. Smile

Lino

Mensajes : 49
Fecha de inscripción : 29/12/2009
Localización : Valencia

Ver perfil de usuario http://twitter.com/moinelo

Volver arriba Ir abajo

Vamos por partes

Mensaje  Lino el Jue Dic 31, 2009 5:37 pm

Al intentar crear el directorio samba con md samba, me dice que no encuentra el comando md.

(Hasta ahora lo había creado con mkdir, pero de esta forma, por el motivo que sea, me dice que es de solo lectura Question confused )

Otra cosa ¿es absolutamente necesario crear ese directorio? Lo digo porque al descomprimir, crea otra carpeta con el mismo nombre. confused confused

Lino

Mensajes : 49
Fecha de inscripción : 29/12/2009
Localización : Valencia

Ver perfil de usuario http://twitter.com/moinelo

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  vic1972 el Jue Dic 31, 2009 5:40 pm

Hola,
vamos por parte.

/tmp/hdd/root # mkdir hola
/tmp/hdd/root # rm -R hola
/tmp/hdd/root # md hola
-sh: md: not found

Yo uso mkdir, ya que md no esta.


En mi lg lo tengo asi:
/tmp/hdd/root/samba/smbd # ls
codepages rc.smbd smb.conf smbstatus
locks readme smbd smbuser.conf
private samba.log smbpasswd
/tmp/hdd/root/samba/smbd #

Obviamente lo puedes montar como tu quieras, pero lo mejor es que manengas todas las
carpetas iguales, asi te evitaras tener que cambiar los scripts de configuración y arranque.

suerte.
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Antes de las uvas

Mensaje  Lino el Jue Dic 31, 2009 8:52 pm

Bueno, esto sigue sin funcionar. Hay dos cosas que no he podido seguir:

1- El archivo descargado no hay que copiarlo a la carpeta samba y descomprimirlo allí, sino en root. De otra forma no coinciden los directorios y da error.
2- No he editado nada en los archivos de configuración

Esto es lo que me sale:

/tmp/hdd/root/samba/smbd # vi rc.smbd
#!/bin/sh

# !!! CHANGE THIS TO THE RIGHT PATH !!!!
SMBD_PATH=/usr/local/etc/hdd/root/samba/smbd
# ---------------------------------------------

# Choose your configuration file
CONF_FILE="${SMBD_PATH}/smbuser.conf"

# --------------------------------------------------------------
# DO NOT CHANGE ANYTHING BELOW UNLESS YOU NOW WHAT YOU ARE DOING

PIDDIR=/var/lock
DEBUGLEVEL=1

stop() {
echo "Stopping samba server..."

[ -L /var/samba ] && rm /var/samba

if [ ! -f "${PIDDIR}/smbd.pid" ]; then
echo Could not find "${PIDDIR}/smbd.pid"
echo "You may need de kill the process manually"
return
fi
read SMBPID < ${PIDDIR}/smbd.pid
if ps | grep -qe "^[ ]*${SMBPID}"; then
kill ${SMBPID} && sleep 1
if ps | grep -qe "^[ ]*${SMBPID}"; then
echo "Process ${SMBPID} not stopped"
echo "You may need de kill the process manually"
else
echo "Stopped"
fi
else
echo "Process ${SMBPID} does not exist (already stopped ?)"
echo "You may need de kill the process manually"
fi
}

start() {
echo "Starting samba server..."

# link /var/samba to smbd directory
ln -s "${SMBD_PATH}" /var/samba

# start smbd
"${SMBD_PATH}/smbd" -d ${DEBUGLEVEL} -D -s "${CONF_FILE}" --piddir=${PIDDIR}
if [ "$?" -eq 0 ]; then
echo "Started"
else
echo "Error $? : Samba server may not be started"
fi
}
- rc.smbd 4/67 5%

Saludos y Feliz Año!!

Lino

Mensajes : 49
Fecha de inscripción : 29/12/2009
Localización : Valencia

Ver perfil de usuario http://twitter.com/moinelo

Volver arriba Ir abajo

Buena entrada de año

Mensaje  Lino el Vie Ene 01, 2010 3:35 pm

Hola. Feliz entrada de año. De momento, la mía ha sido buena. Cool

Hay un corolario de la Ley de Murphy que dice:

La Ciencia es verídica, no te dejes influir con los hechos
Wink

Y así he hecho yo, he confiado en este foro, a pesar de que todos los hechos apuntaban al desastre. Pero no, era yo el equivocado. Razz

YA FUNCIONA EL PUTO SERVIDOR SAMBA. lol!

He editado carácter por carácter los archivos de configuración exactamente igual (INFORTEL lo he cambiado por mi grupo de trabajo) que los mostrados en el tutorial, junto con utilizar las mismas rutas y ya está.

Lo un poco desconcertante, es que no aparece mi equipo (el LGMS450) en entre los demás en la red, aunque si que puede acceder tecleando la IP directamente. Para el instalar la unidad de red, he tenido que ponerle \\192.168.2.8\hdd. Es decir, la IP del aparato y la carpeta que supongo que es la compartida. No podía hacerlo en la raiz directamente, aunque si que puedo navegar por ella. Cosas del Windows supongo.

Gracias

Lino

Mensajes : 49
Fecha de inscripción : 29/12/2009
Localización : Valencia

Ver perfil de usuario http://twitter.com/moinelo

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  vic1972 el Vie Ene 01, 2010 5:56 pm

Hombreeeeeee Wink me alegro

Si, para que funcionen los nomb res de hosts por red, hace falta otro demonio nmbd, que tambien pertenece a samba.
Pero desde mi punto de vista, con esto tenemos mas que suficiente. verdad?

Yo personalmente tengo metida la ip del lg en mi archivo /etc/hosts de mi ordenador, y ya siempre uso cosas como
telnet lg
o
http://lg
o
la carpeta compartida samba la tengo en una especie bookmark.

bueno, bueno, pues hasta la proxima.
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Si, por fin

Mensaje  Lino el Sáb Ene 02, 2010 12:23 am

Es la novatada. A ver si voy con más cuidado la próxima. Razz

Sobre si tengo bastante o no, depende si otros dispositivos media-center podrán acceder al LG. He abierto un hilo en dudas y preguntas para ver como está el tema.

Saludos y gracias por estar ahí.

Lino

Mensajes : 49
Fecha de inscripción : 29/12/2009
Localización : Valencia

Ver perfil de usuario http://twitter.com/moinelo

Volver arriba Ir abajo

Re: Servidor SAMBA

Mensaje  Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 1 de 5. 1, 2, 3, 4, 5  Siguiente

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.