TUTORIAL: PM/LG Menu v103

Página 1 de 2. 1, 2  Siguiente

Ir abajo

TUTORIAL: PM/LG Menu v103

Mensaje  Keltek el Sáb Oct 02, 2010 3:18 am

!!!WARNING!!! Because of nasty bugs in v102 I removed it from SourceForge so please, use this version instead. !!!WARNING!!!

Get the packages at: https://sourceforge.net/projects/lgmenu/files/PM_LGM_v1.0.3/

PipeManagement / LG Menu version 1.0.3
Release date: 2.10.2010

This is update for LG Menu v100 or v101. The incremental update can be performed but you can use this guide to perform full installation.

Changes
- update of PipeManagement to v3.1
- slightly tuned rtorrent start script - sometimes there remains the files, which prevent start the rtorrent process, so we need to remove it
- tuned smb.conf (thanks Co0olCat from Spain forum) for better performance
- added option in Scheduling page to set the destination to external disk in MS450H (HDD+)
- changed the scheduling plan in Scheduling page to make it from "date, time from, length" to "date, time from, time to"
- added version string in LG Menu
- fixed issue (again) with installation problems on MS450H
- removed some debug uoutput in scheduling page
- corectly display the version string

Installation
There is more than one way how to install. Owners of MS450H which don't want to make manual install can take the firmware, flash it and then perform the update procedure. All variants follow:

1) Full install on MS400/MS450 on not flashed/not previously installed package
- put the files "MS400_100417_0148.img", "Custom-KV-v100.tar.gz", "Custom-KV-v103.tar.gz" to the root of USB disk
- put the USB disk into front panel USB port of LG PVR
- press the "Record" button on front panel and keep it pressed
- turn on the LG PVR or (if PVR is on) press the reset button on front panel (left from record button)
- keep pressed the record button until the LG logo appear on screen, then you can release the record button
- after a while, the flashing process will start - wait for flashing process, it will take some time
- after the flashing is done, LG PVR is rebooted
- the PVR went into the INIT screen, at this screen you can proceed with main settings (which can be altered later) but the installation process will continue, the USB is accessed and the first package (v100) is accessed and installed - it can take some time and there is possibility the LG don't react on remote control (the installation package is CPU intensive process)
- after the v100 package is installaed, the PVR is rebooted - keep the USB inserted
- after the second reboot (first was the flashing, second was installation of v100 package) please wait, the update process will install the v103 package (it takes some time because there must be veryfication of v100 package and then the v103 package), after the update the PVR is rebooted automatically
- after the third reboot, you can unplug the USB and wait to boot
- if you have configured the network, you can access the LG Menu by inserting the IP address to web browser
- you have the v103 installed

2) You have flashed and installed the v100 or v101 package and don't want to install v103 manually
- put the files "MS400_100417_0148.img" to the root of USB disk (do not put the packages on it)
- put the USB disk into front panel USB port of LG PVR
- in LG Menu Backup/Restore page, make a backup of current configuration and database files
- press the "Record" button on front panel and keep it pressed and press the reset button on front panel
- keep pressed the record button until the LG logo appear on screen, then you can release the record button
- after a while, the flashing process will start - wait for flashing process, it will take some time
- after the flashing is done, LG PVR is rebooted
- make initial settings (especially network settings)
- access the LG Menu Backup/Restore page and perform restore of previously created backup
- after the restore is done, put the file "Custom-KV-v103.tar.gz" to the root of USB disk, put the USB disk into LG PVR and reboot
- after reboot, the package will be installed automatically, after the installation process is done, PVR is rebooted
- you have the v103 installed

3) You have flashed and installed the v100 or v101 and don't want to flash the firmware - this process will automatically works on MS400 but will not work on MS450
- put the files "Custom-KV-v103.tar.gz" to the root of USB disk
- put the USB disk into front panel USB port of LG PVR
- perform reboot and the update package will be installed automatically
- after the reboot you have the v103 installed

4) You have flashed and installed the v100 or v101 and you are the user of MS450 and don't want to flash the firmware
- put the file "Custom-KV-v103.tar.gz" to the root of USB disk
- put the USB disk into front panel USB port of LG PVR
- wait until the USB is mounted
- perform telnet session, copy the file Custom-KV-v103.tar.gz from USB (mount point is in /tmp/usbmounts) to /tmp/hddmedia/lg/installation directory (if not exists, create it)
- unpack it "cd /tmp/hddmedia/lg/installation; zcat Custom-KV-v103.tar.gz | tr xf -"
- start the installation script "./performUpdate.sh"
- after update is processed, the reboot is performed
- you have the v103 installed

Please, if you have a problems, describe it on the forums or file the ticket at https://sourceforge.net/tracker/?group_id=348378
Thank you...
avatar
Keltek

Mensajes : 291
Fecha de inscripción : 10/03/2010
Edad : 40
Localización : Praha - Czech Republic

Ver perfil de usuario http://www.fozona.cz/

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  vic1972 el Sáb Oct 02, 2010 9:08 am

woww Smile
thanks keltek for your great work.
I will also eliminate old package links, and put newer ones, and modify first post with new links.
thanks thanks thanks thanks
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  maquinabaja el Sáb Oct 02, 2010 12:03 pm

keltek hello, sorry to say that this version can not install and I'm afraid this is why:


if [ -f $chome/etc/version ]; then
current_version=`cat $chome/etc/version`
if [ ${current_version} -eq 102 ]; then
echo "Installed version ${current_version}. Installing..."
performinstall=1
else
echo "Current version = ${current_version}, which is NOT the version 102. Skipping."



I have not tried to change it because it is not as re compress again. tar

Greetings.



avatar
maquinabaja

Mensajes : 150
Fecha de inscripción : 03/01/2010
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  Keltek el Sáb Oct 02, 2010 12:57 pm

I'm very sorry. There must be someone who change the archives for me Wink
Please redownload the v103 package again (it must have size of 734.8kB).
Sorry again...

I know, it is not good solution, but I have prepared the archive but nobody upload it. But upload the bad one Sad
avatar
Keltek

Mensajes : 291
Fecha de inscripción : 10/03/2010
Edad : 40
Localización : Praha - Czech Republic

Ver perfil de usuario http://www.fozona.cz/

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  maquinabaja el Sáb Oct 02, 2010 1:39 pm

Well now, if it is installed automatically.

Just as a comment, still does not work the buttons 4, 6 to advance or rewind the 1, 2, 3 and 5.

Greetings.
avatar
maquinabaja

Mensajes : 150
Fecha de inscripción : 03/01/2010
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  jabb_0904 el Sáb Oct 02, 2010 4:31 pm

maquinabaja escribió:keltek hello, sorry to say that this version can not install and I'm afraid this is why:


if [ -f $chome/etc/version ]; then
current_version=`cat $chome/etc/version`
if [ ${current_version} -eq 102 ]; then
echo "Installed version ${current_version}. Installing..."
performinstall=1
else
echo "Current version = ${current_version}, which is NOT the version 102. Skipping."




I have not tried to change it because it is not as re compress again. tar

Greetings.




Hello, I, using samba, have edited the file performUpdate.sh in the PC, with the notepad, and where it puts 102, have changed it into 101.

Then, I have executed by telnet "sh performUpdate.sh " and installed without problems,

Regards,

jabb_0904

Mensajes : 91
Fecha de inscripción : 31/12/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  vic1972 el Sáb Oct 02, 2010 4:38 pm

maquinabaja escribió:Well now, if it is installed automatically.

Just as a comment, still does not work the buttons 4, 6 to advance or rewind the 1, 2, 3 and 5.

Greetings.



Hello maqui,
I have a clue of the reason, but not sure.
I have sent you a PM. please check Wink
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  Keltek el Sáb Oct 02, 2010 8:54 pm

Hola Victor,
please, can you write to forum http://ms450.forosactivos.net/tutoriales-f4/nuevo-firmware-custom-3-custom3_0148vk-sept-2010-t411-60.htm that the v103 must be redownloaded? (with notice the archive must be more than 700KB in size)
I hope this will nevere repeat again... Sad sorry
avatar
Keltek

Mensajes : 291
Fecha de inscripción : 10/03/2010
Edad : 40
Localización : Praha - Czech Republic

Ver perfil de usuario http://www.fozona.cz/

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  vic1972 el Sáb Oct 02, 2010 9:56 pm

Hello,
its fine,
i have already edited first message in the thread, with the new link to the new packages.
this new package include the good package.
in fact, old packages has even been deleted,
so i think there is even no chance that people gets the old file,
unless something have upload to somewhere else ...

many thanks for your dedication
cheers mate cheers
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  Keltek el Dom Oct 03, 2010 12:05 am

At the Czech forum one report there is another bug in performUpdate.sh Sad
The rcS, starthddservices.sh and PipeManagement is not correctly unpacked. I re-upload new archive.
If anyone flash the firmware with img from v103, it is ok. For other the update of PM and system scripts is recommended.
avatar
Keltek

Mensajes : 291
Fecha de inscripción : 10/03/2010
Edad : 40
Localización : Praha - Czech Republic

Ver perfil de usuario http://www.fozona.cz/

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  vic1972 el Dom Oct 03, 2010 8:47 am

ok, thanks for the note.
I have changed first post, and so, the downloads are now directly from sourceforge.
i think is the best.
thanks for dedication.
avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  jocsen el Dom Oct 03, 2010 1:49 pm

hi all,

As i´ve read for MS400/MS450 not flashed Installation i need three files,

1) Full install on MS400/MS450 on not flashed/not previously installed package
- put the files "MS400_100417_0148.img", "Custom-KV-v100.tar.gz", "Custom-KV-v103.tar.gz" to the root of USB disk

Well I don´t known where i can found "Custom-KV-v100.tar.gz" file in the sourceForge Link.

thanks.
avatar
jocsen

Mensajes : 19
Fecha de inscripción : 13/04/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  Keltek el Dom Oct 03, 2010 2:40 pm

Try this. But take only the v1.0.tar.gz archive...
I'll upload this archive as alone archive later today...
avatar
Keltek

Mensajes : 291
Fecha de inscripción : 10/03/2010
Edad : 40
Localización : Praha - Czech Republic

Ver perfil de usuario http://www.fozona.cz/

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  jocsen el Dom Oct 03, 2010 6:38 pm

Thanks

But the Custom-KV-v1.0.tar.gz file also does not exist in the sourceForge repository and the Dropbox Link given in the pdf tutorial is broken, too.

Don´t worry, i try it tomorrow when you can upload the file.

Thanks
avatar
jocsen

Mensajes : 19
Fecha de inscripción : 13/04/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  Keltek el Dom Oct 03, 2010 7:50 pm

avatar
Keltek

Mensajes : 291
Fecha de inscripción : 10/03/2010
Edad : 40
Localización : Praha - Czech Republic

Ver perfil de usuario http://www.fozona.cz/

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  jocsen el Dom Oct 03, 2010 8:04 pm

thanks

I have installed it, both the new firm and the LGMenu and it´s all ok and in a good properly way. It´s wonderful to see, how for example, the ftp go faster than using the initial firmware, and the Samba, the web application Woooouu Smile

Thanks
avatar
jocsen

Mensajes : 19
Fecha de inscripción : 13/04/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  ftnonen el Mar Oct 05, 2010 10:48 pm

jocsen escribió:thanks

I have installed it, both the new firm and the LGMenu and it´s all ok and in a good properly way. It´s wonderful to see, how for example, the ftp go faster than using the initial firmware, and the Samba, the web application Woooouu Smile

Thanks

Thanks too !

I would suggest to uncomment the lines ( removing the # at the beginning of the line ) for launching the nmbd daemon in the S10samba of the inet.d directory.
I suggest also to add the ability to start an stop the torrent daemon.

Regards.

ftnonen

Mensajes : 10
Fecha de inscripción : 14/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

ExHDD

Mensaje  Apgad el Miér Oct 06, 2010 1:25 am

This firmware is great, and everything works fine except the external HDD. After running 1.03 I can now see ExHDD in windows explorer, but when I try to copy from my PC it says I don't have permission. I don't have this problem copying to the internal HDD. Is this a problem with the firmware, or something I need to fix myself?

Thanks again!

Andrew

Apgad

Mensajes : 42
Fecha de inscripción : 01/06/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  vic1972 el Miér Oct 06, 2010 7:29 am

Hello,
yes this is a known topic.

That is appears as a share, means only that has been added as a new share in the samba config file.
LG mount read only the external drives,
and when lg is going to write, it remount read/write only for that process; afterward set again to read only.

There is a command to remount, but we are thinking that is not a very safe way, and are looking for safer workaround.

Imagine, you copy a very important thing in a usb key; will you unmount this before disconnecting ?




avatar
vic1972

Mensajes : 2260
Fecha de inscripción : 09/12/2009
Edad : 46
Localización : Malaga

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  Co0olCat el Miér Oct 06, 2010 11:10 am

Apgad escribió:
... After running 1.03 I can now see ExHDD in windows explorer, but when I try to copy from my PC it says I don't have permission. I don't have this problem copying to the internal HDD. Is this a problem with the firmware, or something I need to fix myself?

Hi,

This sounds funny, but I have noticed that when LG is writing (recording) to ExHDD, one can modify its content through smb. This is the time when I am doing some housekeeping... Very Happy

Thank you.
Kind regards,
TY

Co0olCat

Mensajes : 17
Fecha de inscripción : 31/01/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  Keltek el Miér Oct 06, 2010 11:31 am

ftnonen escribió:
I would suggest to uncomment the lines ( removing the # at the beginning of the line ) for launching the nmbd daemon in the S10samba of the inet.d directory.
I suggest also to add the ability to start an stop the torrent daemon.

Please, can you tell me the benefit of enabling the nmbd daemon and wasting the memory with it? I don't see any usage for this.
The rtorrent is a service but still not have the control page.
avatar
Keltek

Mensajes : 291
Fecha de inscripción : 10/03/2010
Edad : 40
Localización : Praha - Czech Republic

Ver perfil de usuario http://www.fozona.cz/

Volver arriba Ir abajo

Freezing issue

Mensaje  Apgad el Mar Oct 12, 2010 7:20 am

Since updating to 103, I've noticed that the machine freezes on startup, showing 'HELLO' on the front. I need to manually reboot before it starts up properly. This seems to happen fairly regularly.

Has anyone else had this problem?

Apgad

Mensajes : 42
Fecha de inscripción : 01/06/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  ftnonen el Mar Oct 12, 2010 9:55 am

Keltek escribió:
ftnonen escribió:
I would suggest to uncomment the lines ( removing the # at the beginning of the line ) for launching the nmbd daemon in the S10samba of the inet.d directory.
I suggest also to add the ability to start an stop the torrent daemon.

Please, can you tell me the benefit of enabling the nmbd daemon and wasting the memory with it? I don't see any usage for this.
The rtorrent is a service but still not have the control page.
I was thinking that nmbd is mandatory with samba. Is that true ? If yes then why launching samba without nmdb ?

ftnonen

Mensajes : 10
Fecha de inscripción : 14/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  Keltek el Mar Oct 12, 2010 12:07 pm

ftnonen escribió:
Keltek escribió:
ftnonen escribió:
I would suggest to uncomment the lines ( removing the # at the beginning of the line ) for launching the nmbd daemon in the S10samba of the inet.d directory.
I suggest also to add the ability to start an stop the torrent daemon.

Please, can you tell me the benefit of enabling the nmbd daemon and wasting the memory with it? I don't see any usage for this.
The rtorrent is a service but still not have the control page.
I was thinking that nmbd is mandatory with samba. Is that true ? If yes then why launching samba without nmdb ?
The NMBD is daemon which "provide netbios nameserver support to clients". This component is not needed for file-sharing, but helps with some sort of "searching for service" (this is imho: to support calling device by it's name according using the IP address, but this have some limitation - you can see in documentation it replay for broadcast requests, but the current Venus kernel doesn't support broadcast, so this very welcome feature cannot be used Sad )
So why we launch the SMBD withou NMBD? Simple question witch simple answer - to save some bytes from memory.
The rtorrent service can be controlled in v104 (released soon).

Man page of NMBD: http://www.samba.org/samba/docs/man/manpages-3/nmbd.8.html
avatar
Keltek

Mensajes : 291
Fecha de inscripción : 10/03/2010
Edad : 40
Localización : Praha - Czech Republic

Ver perfil de usuario http://www.fozona.cz/

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  ftnonen el Mar Oct 12, 2010 3:10 pm

Keltek escribió:
ftnonen escribió:
Keltek escribió:
ftnonen escribió:
I would suggest to uncomment the lines ( removing the # at the beginning of the line ) for launching the nmbd daemon in the S10samba of the inet.d directory.
I suggest also to add the ability to start an stop the torrent daemon.

Please, can you tell me the benefit of enabling the nmbd daemon and wasting the memory with it? I don't see any usage for this.
The rtorrent is a service but still not have the control page.
I was thinking that nmbd is mandatory with samba. Is that true ? If yes then why launching samba without nmdb ?
The NMBD is daemon which "provide netbios nameserver support to clients". This component is not needed for file-sharing, but helps with some sort of "searching for service" (this is imho: to support calling device by it's name according using the IP address, but this have some limitation - you can see in documentation it replay for broadcast requests, but the current Venus kernel doesn't support broadcast, so this very welcome feature cannot be used Sad )
So why we launch the SMBD withou NMBD? Simple question witch simple answer - to save some bytes from memory.
The rtorrent service can be controlled in v104 (released soon).

Man page of NMBD: http://www.samba.org/samba/docs/man/manpages-3/nmbd.8.html

So if I don't launch nmbd how to see the LGMS400 using the windows explorer ? Is there any configuration to do ?

ftnonen

Mensajes : 10
Fecha de inscripción : 14/02/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: TUTORIAL: PM/LG Menu v103

Mensaje  Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 1 de 2. 1, 2  Siguiente

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.